<!DOCTYPE html> <html lang="en"> <head data-category_name="yoga-spirituality" data-content_type="Photo Feature Article"> <title>Teachers’ Day 2020: Some Top Gurus And Saints In Hindu Mythology - Boldsky.com</title> <meta http-equiv="content-type" content="text/html; charset=UTF-8"/> <meta name="Generator" content="Greynium CMS"/> <meta name="description" content="This Teachers’ Day i.e., on 5 September 2020, we are here to tell you about some of the top Gurus and Saints in the Hindu Mythology. These were the people who inspired others during their time and gave important teachings. Scroll down the article to read more."/> <meta name="keywords" content="teachers day, teachers day 2020, hindu gurus, saints in hindu mythology,hindu saints,gurus in hindu mythology "/> <meta property="og:type" content="article"/> <meta property="og:site_name" content="https://www.boldsky.com"/> <meta property="article:published_time" content="2020-09-04T18:30:00+05:30" data-published_date="2020-09-04"/> <meta property="article:author" content="Prerna Aditi" data-author="oi-Prerna Aditi" data-match-video="false"/> <meta property="og:title" content="Teachers’ Day 2020: Some Top Gurus And Saints In Hindu Mythology"/> <meta property="og:url" content="https://www.boldsky.com/yoga-spirituality/faith-mysticism/teachers-day-gurus-and-saints-in-hindu-mythology-134531.html"/> <meta property="og:description" content="This Teachers’ Day i.e., on 5 September 2020, we are here to tell you about some of the top Gurus and Saints in the Hindu Mythology. These were the people who inspired others during their time and gave important teachings. Scroll down the article to read more."/> <meta property="fb:app_id" content="335584269785649"/> <meta property="fb:pages" content="166845190089054"/> <meta name="twitter:card" content="summary_large_image"/> <meta name="twitter:site" content="@Boldsky"/> <meta name="twitter:image" content="https://www.boldsky.com/img/2020/09/gurussaints-1599222005.jpg?04092020184005"/> <meta name="twitter:title" content="Teachers’ Day 2020: Some Top Gurus And Saints In Hindu Mythology"/> <meta name="twitter:url" content="https://www.boldsky.com/yoga-spirituality/faith-mysticism/teachers-day-gurus-and-saints-in-hindu-mythology-134531.html?04092020184005"/> <meta name="twitter:description" content="This Teachers’ Day i.e., on 5 September 2020, we are here to tell you about some of the top Gurus and Saints in the Hindu Mythology. These were the people who inspired others during their time and gave important teachings. Scroll down the article to read more."/> <meta name="twitter:creator" content="Boldsky"/> <meta name="twitter:domain" content="https://www.boldsky.com"/> <meta name="DC.date.issued" content="2020-09-04T18:30:00Z"/> <meta name="robots" content="index, follow"/> <link rel="canonical" href="https://www.boldsky.com/yoga-spirituality/faith-mysticism/teachers-day-gurus-and-saints-in-hindu-mythology-134531.html"/> <link rel="amphtml" href="https://www.boldsky.com/amphtml/yoga-spirituality/faith-mysticism/teachers-day-gurus-and-saints-in-hindu-mythology-134531.html"> <link rel="image_src" href="https://www.boldsky.com/img/2020/09/gurussaints-1599222005.jpg"/> <meta property="og:image" content="https://www.boldsky.com/img/2020/09/gurussaints-1599222005.jpg"/> <link rel="shortcut icon" href="/favicon.ico"/> <script type="application/ld+json">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</script> <script type="application/ld+json">
{
        "@context" : "https://schema.org",
        "@type": "WebPage",
        "description": "This Teachers’ Day i.e., on 5 September 2020, we are here to tell you about some of the top Gurus and Saints in the Hindu Mythology. These were the people who inspired others during their time and gave important teachings. Scroll down the article to read more." ,
         "url":"https://www.boldsky.com/yoga-spirituality/faith-mysticism/teachers-day-gurus-and-saints-in-hindu-mythology-134531.html",
        "name": "Teachers’ Day 2020: Some Top Gurus And Saints In Hindu Mythology"
}
</script> <script type="application/ld+json">
        {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.boldsky.com"},{"@type":"ListItem","position":2,"name":"yoga-spirituality","item":"https:\/\/www.boldsky.com\/yoga-spirituality\/"},{"@type":"ListItem","position":3,"name":"faith-mysticism","item":"https:\/\/www.boldsky.com\/yoga-spirituality\/faith-mysticism\/"}]}
     </script> <link href="https://fonts.googleapis.com/icon?family=Material+Icons" rel="stylesheet"> <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet"> <link rel='stylesheet' type='text/css' href="/common/adaptive/css/header-footer-style.css?v=25"> <link rel='stylesheet' type='text/css' href="/common/adaptive/css/common-article.css?v=1.0.19"> <link type="text/css" rel="stylesheet" href="/common/min/?b=common/adaptive/css&f=article-style.css,article-listicle.css,newsletter.css,selection-sharer.css&v=72"/> <script data-pagespeed-no-defer>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</script> <script data-pagespeed-no-defer>function fetchConsSts(){window.googlefc=window.googlefc||{};window.googlefc.callbackQueue=window.googlefc.callbackQueue||[];return new Promise(resolve=>{googlefc.callbackQueue.push({'CONSENT_DATA_READY':function(){resolve(googlefc.getConsentStatus());}});});}</script> <link rel="manifest" href="/browser.json?v=1.0.1" pagespeed_no_defer=""> <meta name="p:domain_verify" content="ef3e2e62395da22fc101d11e1eeebd68"/> <link href="https://www.google.com/analytics" rel="dns-prefetch"/> <link href="https://www.zedo.com/" rel="dns-prefetch"/> <link href="https://www.doubleclickbygoogle.com/" rel="dns-prefetch"/> <link href="https://adgebra.co.in" rel="dns-prefetch"/> <link href="https://vuukle.com/" rel="dns-prefetch"/> <link href="https://hindi.boldsky.com/" rel="dns-prefetch"/> <link href="https://gujarati.boldsky.com/" rel="dns-prefetch"/> <link href="https://bengali.boldsky.com/" rel="dns-prefetch"/> <link href="https://kannada.boldsky.com/" rel="dns-prefetch"/> <link href="https://malayalam.boldsky.com/" rel="dns-prefetch"/> <link href="https://tamil.boldsky.com/" rel="dns-prefetch"/> <link href="https://telugu.boldsky.com/" rel="dns-prefetch"/> <script type='text/javascript' data-pagespeed-no-defer>var MyApi={};var VUUKLE_CONFIG={};var googletag=googletag||{};googletag.cmd=googletag.cmd||[];var slot1;var photoGalleryGlobal={};var photoFeatureGlobal={};var clSliderGlobal={};var pf_mobi_slider;var mySwipe;var slot=[];var pfGlobalData={};var oi_setting=new Object();var social_share=new Object();var _qevents=_qevents||[];var twitter_via="Boldsky";var contentid;var author_page=new Object();var gf_search_data=new Object();var enabled_noti;var loadContent=false;var oldID=0;var lastScrollTop=0;var next_data_url;var prev_data_url;var next_data_cache;var prev_data_cache;var last_scroll=0;var is_loading=0;var hide_on_load=false;var ptype;var slider_product={};var gaStopCounter=10;var current_url=location.href;var adPerSeen=50;var adTimeInterval=30;var refreshTimeOut=0;var adPerSeenMobi=50;var adTimeIntervalMobi=40;var bottomStickySlot;if(document.querySelector('meta[property="article:author"]')){var ga_author_name=document.querySelector('meta[property="article:author"]').getAttribute('data-author').trim();}if(document.querySelector('meta[property="article:published_time"]')){var ga_published_date=document.querySelector('meta[property="article:published_time"]').getAttribute('data-published_date').trim();}if(document.querySelector('link[rel="canonical"]')){var canonical_url=document.querySelector('link[rel="canonical"]').getAttribute('href').trim();}var data_match_vdo=false;if(document.querySelector('meta[property="article:author"]')){data_match_vdo=document.querySelector('meta[property="article:author"]').getAttribute('data-match-video').trim();}var direct_ad_refresh=localStorage.getItem("direct_ad");if(direct_ad_refresh==""||direct_ad_refresh=="undefined"||direct_ad_refresh==null){direct_ad_refresh="";}</script> <script type='text/javascript' data-pagespeed-no-defer>var promotional_details={promoflag:0,promolink:['https://www.boldsky.com/health/wellness/2018/5-common-health-issues-you-should-not-neglect-121798.html'],promolimit:3};</script> <script type='text/javascript' data-pagespeed-no-defer>var _sf_startpt=(new Date()).getTime()</script> <script type='text/javascript'>var gutter_ad=0;var non_gutter_ad=1;var com_cnt;</script> <script type='text/javascript' data-pagespeed-no-defer>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"7732551"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script> <script data-pagespeed-no-defer>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-110466-90','auto',{'name':'boldskyen'});ga('create','UA-110466-3','auto',{'name':'rosboldsky'});if(ga_author_name!=undefined&&ga_author_name!=""){ga('boldskyen.set','dimension1',ga_author_name);}if(ga_published_date!=undefined&&ga_published_date!=""){ga('boldskyen.set','dimension3',ga_published_date);}if(canonical_url.length>0){ga('boldskyen.set','dimension4',canonical_url);}ga('boldskyen.send','pageview');ga('rosboldsky.send','pageview');</script> <script src="https://pixel.zprk.io/v5/pixeljs/2QMgbCMHov.js" async></script> <script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "potentialAction": {
     "@type": "SearchAction",
     "target": "https://www.boldsky.com/search/results.html?q={search_term_string}",
     "query-input": "required name=search_term_string"
   },
  "name" : "Boldsky",
  "url" : "https://www.boldsky.com",
  "logo": {
      "@type": "ImageObject",
      "url": "https://www.boldsky.com/images/amp-boldsky-logo.png",
      "width": 192,
      "height": 60
    },
"sameAs" : [ "https://www.facebook.com/boldsky.com",
		    "https://twitter.com/Boldsky"]
}
</script> <script data-pagespeed-no-defer>function setUserCookie(name,value,expires,path,domain,secure){var chkcookiepolicy=getUserCookie('cookiePolicy');console.log(chkcookiepolicy);if(chkcookiepolicy!=0){var today=new Date();today.setTime(today.getTime());if(expires){expires=expires*1000*60*60;}var expires_date=new Date(today.getTime()+(expires));document.cookie=name+'='+escape(value)+((expires)?';expires='+expires_date.toGMTString():'')+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+((secure)?';secure':'');}}function deleteUserCookie(name,path,domain){if(getCookie(name))document.cookie=name+'='+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+';expires=Thu, 01-Jan-1970 00:00:01 GMT';}function checkUserCookie(cookie_name){var location_details=getUserCookie(cookie_name);if(location_details==null||location_details==""){return false;}else if(location_details!=""){return true;}}function checkUserCookie(cookie_name){var location_details=getUserCookie(cookie_name);if(location_details==null||location_details==""){return false;}else if(location_details!=""){return true;}}function getUserCookie(c_name){var c_value=document.cookie;var c_start=c_value.indexOf(" "+c_name+"=");if(c_start==-1){c_start=c_value.indexOf(c_name+"=");}if(c_start==-1){c_value=null;}else{c_start=c_value.indexOf("=",c_start)+1;var c_end=c_value.indexOf(";",c_start);if(c_end==-1){c_end=c_value.length;}c_value=unescape(c_value.substring(c_start,c_end));}return c_value;}</script> <script type="text/javascript">var utmFlag=0;var utmParam=window.location.search;if(utmParam!=''){if(utmParam.includes("?utm_source=desipearl&utm_campaign=desipearl&utm_medium=paid")){utmFlag=1;}}</script> <script type="text/javascript" data-pagespeed-no-defer>var rand_val='';</script> <script data-pagespeed-no-defer async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script data-pagespeed-no-defer async="async" src="/common/oijs/prebid.js?v=1.0.10"></script> <script pagespeed_no_defer="">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</script> <script type="text/javascript" data-pagespeed-no-defer>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</script> <script data-pagespeed-no-defer>//<![CDATA[
(function(){function f(a,b,d){if(a.addEventListener)a.addEventListener(b,d,!1);else if(a.attachEvent)a.attachEvent("on"+b,d);else{var c=a["on"+b];a["on"+b]=function(){d.call(this);c&&c.call(this)}}};window.pagespeed=window.pagespeed||{};var g=window.pagespeed;function k(a){this.g=[];this.f=0;this.h=!1;this.j=a;this.i=null;this.l=0;this.b=!1;this.a=0}function l(a,b){var d=b.getAttribute("data-pagespeed-lazy-position");if(d)return parseInt(d,0);var d=b.offsetTop,c=b.offsetParent;c&&(d+=l(a,c));d=Math.max(d,0);b.setAttribute("data-pagespeed-lazy-position",d);return d}
function m(a,b){var d,c,e;if(!a.b&&(0==b.offsetHeight||0==b.offsetWidth))return!1;a:if(b.currentStyle)c=b.currentStyle.position;else{if(document.defaultView&&document.defaultView.getComputedStyle&&(c=document.defaultView.getComputedStyle(b,null))){c=c.getPropertyValue("position");break a}c=b.style&&b.style.position?b.style.position:""}if("relative"==c)return!0;e=0;"number"==typeof window.pageYOffset?e=window.pageYOffset:document.body&&document.body.scrollTop?e=document.body.scrollTop:document.documentElement&&
document.documentElement.scrollTop&&(e=document.documentElement.scrollTop);d=window.innerHeight||document.documentElement.clientHeight||document.body.clientHeight;c=e;e+=d;var h=b.getBoundingClientRect();h?(e=h.top-d,c=h.bottom):(h=l(a,b),d=h+b.offsetHeight,e=h-e,c=d-c);return e<=a.f&&0<=c+a.f}
k.prototype.m=function(a){p(a);var b=this;window.setTimeout(function(){var d=a.getAttribute("data-pagespeed-lazy-src");if(d)if((b.h||m(b,a))&&-1!=a.src.indexOf(b.j)){var c=a.parentNode,e=a.nextSibling;c&&c.removeChild(a);a.c&&(a.getAttribute=a.c);a.removeAttribute("onload");a.tagName&&"IMG"==a.tagName&&g.CriticalImages&&f(a,"load",function(){g.CriticalImages.checkImageForCriticality(this);b.b&&(b.a--,b.a||g.CriticalImages.checkCriticalImages())});a.removeAttribute("data-pagespeed-lazy-src");a.removeAttribute("data-pagespeed-lazy-replaced-functions");
c&&c.insertBefore(a,e);if(c=a.getAttribute("data-pagespeed-lazy-srcset"))a.srcset=c,a.removeAttribute("data-pagespeed-lazy-srcset");a.src=d}else b.g.push(a)},0)};k.prototype.loadIfVisibleAndMaybeBeacon=k.prototype.m;k.prototype.s=function(){this.h=!0;q(this)};k.prototype.loadAllImages=k.prototype.s;function q(a){var b=a.g,d=b.length;a.g=[];for(var c=0;c<d;++c)a.m(b[c])}function t(a,b){return a.a?null!=a.a(b):null!=a.getAttribute(b)}
k.prototype.u=function(){for(var a=document.getElementsByTagName("img"),b=0,d;d=a[b];b++)t(d,"data-pagespeed-lazy-src")&&p(d)};k.prototype.overrideAttributeFunctions=k.prototype.u;function p(a){t(a,"data-pagespeed-lazy-replaced-functions")||(a.c=a.getAttribute,a.getAttribute=function(a){"src"==a.toLowerCase()&&t(this,"data-pagespeed-lazy-src")&&(a="data-pagespeed-lazy-src");return this.c(a)},a.setAttribute("data-pagespeed-lazy-replaced-functions","1"))}
g.o=function(a,b){function d(){if(!(c.b&&a||c.i)){var b=200;200<(new Date).getTime()-c.l&&(b=0);c.i=window.setTimeout(function(){c.l=(new Date).getTime();q(c);c.i=null},b)}}var c=new k(b);g.lazyLoadImages=c;f(window,"load",function(){c.b=!0;c.h=a;c.f=200;if(g.CriticalImages){for(var b=0,d=document.getElementsByTagName("img"),r=0,n;n=d[r];r++)-1!=n.src.indexOf(c.j)&&t(n,"data-pagespeed-lazy-src")&&b++;c.a=b;c.a||g.CriticalImages.checkCriticalImages()}q(c)});b.indexOf("data")&&((new Image).src=b);f(window,
"scroll",d);f(window,"resize",d)};g.lazyLoadInit=g.o;})();

pagespeed.lazyLoadInit(true, "/img/loading.gif");

//]]></script></head> <body> <div id="all-page-wrapper"> <div id="fullwrapper_header"> <header> <div class="header"> <div class="header-top clearfix"> <div class="header-left"> <div class="logo"><a href="/"></a></div> <div class="giz-lang"> <a href="javascript:void(0);" class="clearfix" id="giz-language"> <span>ENGLISH</span> <i class="material-icons">&#xE5C5;</i> </a> </div> </div> <div class="header-right"> <div class="header-nav"> <nav class="clearfix"> <ul class="clearfix header-nav-left"> <li> <a href="javascript:void(0);" class="clearfix" id="health"> <span>HEALTH</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="beauty"> <span>BEAUTY</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="astrology"> <span>ASTROLOGY</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="spirituality"> <span>VIDEOS</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="pregnancy"> <span>PREGNANCY</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="recipes"> <span>RECIPES</span><i class="material-icons">&#xE313;</i> </a> </li> </ul> <ul class="clearfix header-nav-right"> <li class="giz-search clearfix" style="cursor: pointer;"> <i class="material-icons">&#xE8B6;</i> </li> <li class="extensionElem" style=" display: none; "> <div class="get-extension" style="display: none;"><i class="arrow-up"></i> Get <span>Boldsky</span> extension</div> <a class="browser_extension" href="" target="_blank" style="float: left;margin: -2px -7px!important;"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABkAAAAZCAMAAADzN3VRAAAANlBMVEXZ2dn////Z2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dmW4sRqAAAAEXRSTlMAABAgMEBQYHCAj5+vv8/f7/4ucL8AAACRSURBVCjPvdJJDsMgAENRl6EUCMO//2W7CKlAsK5XEU+KjIU04mN0kvR68kAAeJ+kA5STANBPUgGuk7gOzS5i/J0MeXwO+bAl3BJ3if+X1lYxsVxeEYKUZikVQNY7SWrbP591yi6hFCe5+ax1AEXoKfWlgWuQfq2zMfl4nzrVWCVNNVZpRrLndep4JYfd5Nfdvp8xGL2gFk6uAAAAAElFTkSuQmCC" alt="Browser Extension" title="For latest news install this browser extension." data-pagespeed-no-defer=""></a> </li> <li class="notification_bell"> <style type="text/css">
        .overlay {position: fixed;top: 0;right: 0;left: 0;bottom: 0;background: rgba(0,0,0,0.8);z-index: 100000;}
                        .addr-bar {position: fixed;left: 0;top: 0;z-index: 1000000;}
                        .arrow {position: fixed;left: 120px;top: 40px;z-index: 1000000;}
                        .click-unblock {position: fixed;left: 250px;padding: 20px 10px;background: #0c8043;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000;top: 200px;border-radius: 5px;width: 320px;text-align: center;}
                        .click-unblock img {vertical-align: middle;}
                        .click-close {position: fixed;right: 100px;padding: 15px 30px;background: #4c4c4c;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000;top: 120px;border-radius: 5px;cursor: pointer;}
                        .notf-sampletext {font-size: 16px;color: #fff;font-family: Arial, Helvetica, sans-serif;position: fixed;top: 110px;left: 250px;width: 320px;z-index: 1000000;line-height: 20px;}
                        .site {margin: o auto;text-align: center;}
                        .subscribe-box {text-align: center;position: fixed;left: 250px;top: 260px;width: 445px;height: 344px;margin: auto;z-index: 1000000;}
                        .manage-notification-block-top img {margin: 0;}
.manage-notification-block-firefox-content {
    width: 600px;
    position: fixed;
    top: 0;
    left: 0;
    right: 0; 
    bottom: 0;
    margin: auto;
    padding: 20px;
    background: #fff;
    z-index: 1000000000;
    height: 320px;
    font-family: Arial;
}
                        .manage-notification-block-top-firefox ul {margin-left: 20px;}
                        .manage-notification-block-top-firefox ul li {
    padding: 3px 0; 
    font-size: 16px;
    color: #000;
    list-style-type: decimal;
}   
.manage-notification-heading {font-weight: bold;}
.click-close-firefox {position: fixed;right: 100px;padding: 15px 30px;background: #4c4c4c;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000000;top: 120px;border-radius: 5px;cursor: pointer;}
</style> <div class="nav-notification"> <a href="javascript:void(0);" class="notification-bell ismovement" style="cursor: pointer; display: block; float: left;display: none;" id="notification_bell"><span class="notification-num" style="display: none;"></span><img data-pagespeed-lazy-src="/images/bell.svg" width="25" height="25" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"></a> </div> <div class="nav-notification"> <a href="javascript:void(0);" class="notification-bell-inactive" style="cursor: pointer; float: left; display: none;display: none;" id="notification_bell_inactive"><img data-pagespeed-lazy-src="/images/bell-1.svg" width="25" height="25" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"></a> </div> <div class="manage-notification" style="display: none;"> <div class="manage-notification-close"> <i class="fa fa-close"></i> </div>
You can manage your notification subscription by clicking on the icon
</div> <div class="manage-notification-block-top" style="display: none;"> <div class="addr-bar"><img src="https://images.oneindia.com/notification/images/addr-bar.png?q=1" alt="" data-pagespeed-no-defer /></div> <div class="overlay" style=""></div> <div class="arrow"><img src="https://images.oneindia.com/notification/images/arrow1.png" alt="" data-pagespeed-no-defer /></div> <div class="notf-sampletext">To start receiving timely alerts, as shown below click on the Green “lock” icon next to the address bar</div> <div class="click-unblock"><img src="https://images.oneindia.com/notification/images/lock.png" alt="" data-pagespeed-no-defer /> Click it and Unblock the Notifications</div> <div class="click-close">Close X</div> <div class="subscribe-box"><img src="https://images.oneindia.com/notification/images/subscribe-box.png" alt="" data-pagespeed-no-defer /></div> </div> <div class="manage-notification-block-top-firefox" style="display: none;"> <div class="overlay" style=""></div> <div class="click-close-firefox">Close X</div> <div class="manage-notification-block-firefox-content"> <div class="manage-notification-heading">To Start receiving timely alerts please follow the below steps:</div> <ul> <li>Click on the Menu icon of the browser, it opens up a list of options.</li> <li>Click on the “Options ”, it opens up the settings page,</li> <li>Here click on the “Privacy & Security” options listed on the left hand side of the page.</li> <li>Scroll down the page to the “Permission” section .</li> <li>Here click on the “Settings” tab of the Notification option.</li> <li>A pop up will open with all listed sites, select the option “ALLOW“, for the respective site under the status head to allow the notification.</li> <li>Once the changes is done, click on the “Save Changes” option to save the changes.</li> </ul> </div> </div> <div class="notification-wrapper" style="display: none;"> <div class="notification-arrow"></div> <div class="popup-notification-header clearfix"> <div class="popup-notification-text"> <i class="fa fa-arrow-left"></i> Notifications
</div> <div class="popup-notification-on-off onstate"> <span class="on-off-link"></span> </div> </div> <div class="notification-content"> <div id="notf-cont"> <div class="notification-clear"><a href="javascript:void(0);">Clear All</a></div> <ul id="not-content"></ul> </div> <div class="notification-text" style="display: none;">No Notifications</div> </div> </div> </li> </ul> <div class="header-search-block" style="display: none;"> <input type="text" name="search" id="oneindia_search" placeholder="Enter the search value" style="float: left; width: 300px;height: 21px;padding: 0px;border: none!important;"> <div style="width: 20px;height: 18px;float:  left;padding-left: 12px;"> <div class="one-search-btn"><i class="material-icons">&#xE8B6;</i></div> </div> </div> </nav> <div class="vuukle-powerbar headerVuukleContainer giz-share-block"></div> </div> </div> </div> <div class="header-nav-show"> <div id="giz-language-block"> <ul class="clearfix"> <li> <span class="allLanguages">Also available in:</span> </li> <li> <a href="http://hindi.boldsky.com/" target="_blank" class="lang-hindi">हिन्दी</a> </li> <li> <a href="http://kannada.boldsky.com/" target="_blank" class="lang-kannada">ಕನ್ನಡ</a> </li> <li> <a href="http://malayalam.boldsky.com/" target="_blank" class="lang-malyalam">മലയാളം</a> </li> <li> <a href="http://tamil.boldsky.com/" target="_blank" class="lang-tamil">தமிழ்</a> </li> <li> <a href="http://telugu.boldsky.com/" target="_blank" class="lang-telugu">తెలుగు</a> </li> <li> <a href="http://bengali.boldsky.com/" target="_blank" class="lang-bengali">বাংলা</a> </li> <li> <a href="http://gujarati.boldsky.com/" target="_blank" class="lang-gujarati last">ગુજરાતી</a> </li> </ul> </div> </div> <div class="giz-sub-sec-menu" itemscope="" itemtype="https://www.schema.org/SiteNavigationElement"> <div class="giz-sub-menu-block health-block"> <h3><a href="/health/">HEALTH</a></h3> <ul class="clearfix"> <li> <a href="/health/wellness/">Wellness </a> </li> <li> <a href="/health/nutrition/">Nutrition</a> </li> <li> <a href="/health/diet-fitness/">Diet &amp; Fitness</a> </li> <li> <a href="/health/diabetes/">Diabetes</a> </li> <li> <a href="/health/disorders-cure/">Disorder &amp; Cure</a> </li> <li> <a href="/experts/doctors">Experts</a> </li> <li> <a href="/tools/">Tools</a> </li> </ul> </div> <div class="giz-sub-menu-block beauty-block"> <h3><a href="/beauty/">BEAUTY</a></h3> <ul class="clearfix"> <li> <a href="/beauty/skin-care/">Skin Care</a> </li> <li> <a href="/beauty/hair-care/">Hair Care</a> </li> <li> <a href="/beauty/body-care/">Body Care</a> </li> <li> <a href="/beauty/make-up-tips/">Makeup</a> </li> <li><a href="/fashion/"><b>FASHION</b></a></li> <li> <a href="/fashion/bollywood-wardrobe/">Celebrity Wardrobe</a> </li> <li> <a href="/fashion/">Fashion Trends</a> </li> </ul> </div> <div class="giz-sub-menu-block astrology-block"> <h3><a href="/astrology/">ASTROLOGY </a></h3> <ul class="clearfix"> <li> <a href="/astrology/horoscope/">Horoscope</a> </li> <li> <a href="/astrology/palmistry/">Palmistry</a> </li> <li> <a href="/astrology/remedies/">Remedies</a> </li> <li> <a href="/astrology/zodiac-signs/">Zodiac Sign</a> </li> <li> <a href="/astrology/numerology/">Numerology </a> </li> <li><a href="/insync/"><b>INSYNC</b></a></li> <li> <a href="/insync/life/">Life</a> </li> <li> <a href="/insync/pulse/">Pulse</a> </li> </ul> </div> <div class="giz-sub-menu-block spirituality-block"> <h3><a href="/videos/">VIDEOS </a></h3> <ul class="clearfix"> <li> <a href="/videos/astrology-c5/">Astrology</a> </li> <li> <a href="/videos/beauty-c4/">Beauty</a> </li> <li> <a href="/videos/diy-c10/">DIY</a> </li> <li> <a href="/videos/entertainment-c22/">Entertainment</a> </li> <li> <a href="/videos/fashion-c8/">Fashion</a> </li> <li> <a href="/videos/festival-c26/">Festival</a> </li> <li> <a href="/videos/health-c3/">Health</a> </li> <li> <a href="/videos/yoga-c1/">Yoga</a> </li> </ul> </div> <div class="giz-sub-menu-block pregnancy-block"> <h3><a href="/pregnancy-parenting/">PREGNANCY</a></h3> <ul class="clearfix"> <li> <a href="/pregnancy-parenting/prenatal/">Pre Natal</a> </li> <li> <a href="/pregnancy-parenting/postnatal/">Post Natal</a> </li> <li> <a href="/pregnancy-parenting/basics/">Basics</a> </li> <li> <a href="/pregnancy-parenting/baby/">Baby</a> </li> <li> <a href="/pregnancy-parenting/kids/">Kids</a> </li> <li> <a href="/baby-names/ ">Baby Names</a> </li> </ul> </div> <div class="giz-sub-menu-block recipes-block"> <h3><a href="/recipes/">RECIPES</a></h3> <ul class="clearfix"> <li> <a href="/cookery/vegetarian/">Vegetarian</a> </li> <li> <a href="/cookery/non-vegetarian/">Non Vegetarian</a> </li> <li> <a href="/cookery/soups-snacks-drinks/">Snacks</a> </li> <li> <a href=" /cookery/vegetarian/salads/">Salads</a> </li> <li> <a href="/cookery/vegetarian/pickles/">Pickles</a> </li> </ul> </div> <div class="more-links"> <ul> <li><h3><a href="javascript:void(0);"><b>MORE :</b></a></h3></li> <li> <a href="/news/">NEWS </a> </li> <li> <a href="/topic/home-remedies">HOME REMEDIES </a> </li> <li> <a href="/yoga-spirituality/ ">SPIRITUALITY </a> </li> <li> <a href="/relationship/">RELATIONSHIP</a> </li> <li> <a href="/home-n-garden/">HOME &amp; GARDEN</a> </li> <li> <a href="/women/">WOMEN</a> </li> <li> <a href="/lgbtq/">LGBTQ</a> </li> </ul> </div> </div> </div> </header> <div class="cmscontent-top inhouse-content" style="display:block;" id="cmscontent-top" data-zoneId='{"backfill":"71","inhouse":"67"}' data-reviveId='{"backfill":"9de4f035bc8106094a8824fc0cfb6de3","inhouse":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div class="header-post" style="text-align: center;padding-top: 60px;min-height: 90px;margin-bottom: 10px;"> <div id="div-gpt-ad-1409113476519-0" class="oiad oi-axt" data-adval="0" data-elementid="0" data-exec="0"></div> </div> </div> <style>
.vtn-iframe-breakout{
	clear:both;
}
.header {
  z-index: 99999;
}

	.more-links{
		clear: both;
		padding-top: 8px;
	}
	.more-links ul li{
		display: inline-block;
		
	}
	.more-links ul li a{
		border: 1px solid #dbdbdb;
		background: #DCDCDC;
		margin: 0 10px;
	}
	.vtn-iframe-breakout{
	clear:both;
}
.header-nav-left li a{
	padding: 0 9px;
}
</style> </div> <div id="wrapper" data-slideshow="false" data-video-flag="false"> <div id="containerMain" data-page_type="article" data-publidhed_date="2020-09-04" data-video-info="" data-video-position="" data-adcont_identity="false" data-comments="yes" data-article-type=""></div> <div id="container" data-content_id="134531" data-category_name="yoga-spirituality" data-category_id="89" data-con_line="/yoga-spirituality/faith-mysticism/"> <div id="content_container_1"> <div class="content_left_article"> <div class="new_article_width" id="zedo_ad_content"> <div class="new_main_story_width io-article-body" id="story" data-io-article-url="https://www.boldsky.com/yoga-spirituality/faith-mysticism/teachers-day-gurus-and-saints-in-hindu-mythology-134531.html"> <div id="d_social_media"></div> <article> <div class="ecom-ad-content"> <div class="oiMiddleMain"> <div class="oi-article-rt"><div id="giz-subscribe"> <div class="giz-subscribe"> <div class="giz-subscribe-head">
For Quick Alerts
</div> <div class="giz-subscribe-block">
Subscribe Now
<a href="javascript:void(0);" class="notification-bell" id="notification_bell_left"> <i class="bell-icon">&nbsp;</i> </a> </div> <div class="giz-view-sample"> <div class="giz-sample-article"> <div class="sample-image"> <a href="https://www.boldsky.com/health/disorders-cure/2019/hypertrophic-cardiomyopathy-symptoms-causes-diagnosis-treatment-127672.html" target="_blank"> <img src="https://www.boldsky.com/img/100x90x100/2019/03/xcoverimage-1551698619.jpg.pagespeed.ic.O_OeGnyjjm.jpg" data-pagespeed-no-defer /> </a> </div> <div class="sample-text"> <a href="https://www.boldsky.com/health/disorders-cure/2019/hypertrophic-cardiomyopathy-symptoms-causes-diagnosis-treatment-127672.html" target="_blank">
Hypertrophic Cardiomyopathy: Symptoms, Causes, Treatment And Prevention
</a> </div> <div class="clearfix"></div> </div> <div class="gizbot-sample-link"> <a href="javascript:void(0);">View Sample</a> </div> </div> </div> </div> <div id="giz-unsubscribe"> <div class="giz-subscribe block"> <div class="giz-subscribe-head">
For Quick Alerts
</div> <div class="giz-subscribe-block">
ALLOW NOTIFICATIONS
<a href="javascript:void(0);" id="notification_bell_unsub" class="notification_bell_unsub"> <i class="bell-icon">&nbsp;</i> </a> </div> </div> </div> <div id="giz-emailsubscribe"> <div class="giz-subscribe block"> <div class="giz-subscribe-head">
For Daily Alerts
</div> <div class="giz-subscribe-block"> <form target="_blank" class="nospace" action="https://app5.saymails.com/cgi-bin/useradd.pl" method="post" name="newsletter_subscribeform" id="newsletter"> <input type="hidden" name="city" id="newsletter_city"> <input type="hidden" name="country" id="newsletter_country"> <input type="hidden" name="dbname1" value="b25laW5kaWE="> <input type="hidden" name="listname1" value="Ym9sZHNreQ=="> <input type="hidden" name="action1" value="useradd"> <div class="giz-subscribe-textbox"> <input type="text" name="email" placeholder="Enter Your Email Address" class="newsletter-textbox" id="email"> </div> <div class="giz-subscribe-button"> <input type="submit" name="subscribe" value="Sign Up" onclick="return postformById('useradd',this.form);" class="sub-btn"> </div> </form> </div> </div> </div> <div class="cmscontent-left-article inhouse-content" id="cmscontent-left-article" data-zoneid='{"inhouse":61,"backfill":69}' data-reviveid='{"inhouse":"9de4f035bc8106094a8824fc0cfb6de3","backfill":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div id="div-gpt-ad-1431494114668-6" class="oiad inArticleRight oi-axt" data-exec=0 data-adval=0 data-elementid="3"></div> </div> <div class="oi-related"> <h2 class="oi-left-heading">Just In <i class="watch-icon"></i></h2> <ul> <li class="clearfix"> <span class="timestamp">40 min ago</span> <a href="/fashion/bollywood-wardrobe/kajal-aggarwal-and-anasuya-bharadwaj-gives-fashion-goals-for-upcoming-festivals-134529.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Kajal Aggarwal’s Simple Outfit Or Anasuya Bharadwaj’s Stylish Number, Which One Will You Prefer?" data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/09/xcover-1599221474.jpg.pagespeed.ic.6NrGfWPBXT.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="/fashion/bollywood-wardrobe/kajal-aggarwal-and-anasuya-bharadwaj-gives-fashion-goals-for-upcoming-festivals-134529.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Kajal Aggarwal’s Simple Outfit Or Anasuya Bharadwaj’s Stylish Number, Which One Will You Prefer?</a> </li> <li id="nanoWdOut" class="clearfix"> <div class="OUTBRAIN" data-src="https://www.boldsky.com/" data-widget-id="AR_5" data-ob-template="GreyniumInformationTechnologiesPvt.Ltd"></div> </li> <li class="clearfix"> <span class="timestamp">48 min ago</span> <a href="/fashion/bollywood-wardrobe/ishaan-khatter-s-on-screen-fashion-in-movies-like-dhadak-a-suitable-boy-and-khaali-peeli-134530.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Khali Peeli Actor Ishaan Khatter’s On-Screen Fashion Explains His Diverse Characters " data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/09/ximg-04092020-172734-600-x-450-pixel-1599221726.jpg.pagespeed.ic.bspthD1HQ5.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="/fashion/bollywood-wardrobe/ishaan-khatter-s-on-screen-fashion-in-movies-like-dhadak-a-suitable-boy-and-khaali-peeli-134530.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Khali Peeli Actor Ishaan Khatter’s On-Screen Fashion Explains His Diverse Characters </a> </li> <li class="clearfix"> <span class="timestamp">3 hrs ago</span> <a href="/fashion/bollywood-wardrobe/petta-actress-malavika-mohanan-gives-fashion-goals-to-newly-wed-brides-in-red-saree-134527.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Malavika Mohanan Gives Newly-Wed Bridal Vibes In Her Pretty Red Saree, On-Point Jewellery And Alta" data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/09/xcover-1599210767.jpg.pagespeed.ic.0mjHoIBvOQ.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="/fashion/bollywood-wardrobe/petta-actress-malavika-mohanan-gives-fashion-goals-to-newly-wed-brides-in-red-saree-134527.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Malavika Mohanan Gives Newly-Wed Bridal Vibes In Her Pretty Red Saree, On-Point Jewellery And Alta</a> </li> <li class="clearfix"> <span class="timestamp">3 hrs ago</span> <a href="/recipes/egg-noodles-recipe-134528.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Try This Easy Egg Noodles/ Chow Mein Recipe " data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/09/ing-01-1599211292.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="/recipes/egg-noodles-recipe-134528.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Try This Easy Egg Noodles/ Chow Mein Recipe </a> </li> </ul> </div> <div id="div-gpt-ad-1576766006066-0"></div> <div id="article-video-block-new"> <div class="oi-left-heading"><a href="/videos/" target="_blank">Must Watch <i class="video-play-icon"></i></a></div> </div> <div class="oi-related bd-related-videos"> <h2 class="oi-left-heading">Don't Miss <i class="exclamation-icon" style="height: 20px;"></i></h2> <ul id="verticleLinks"> <li class="clearfix"> <a href="https://www.filmibeat.com"><span class="timestamp">Movies</span></a> <a href="https://www.filmibeat.com/television/news/2020/sidharth-shukla-beats-harshad-chopda-asim-riaz-to-become-times-most-desirable-men-on-tv-2019-303535.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Sidharth Shukla Beats Harshad Chopda &amp; Asim Riaz To Become Times Most Desirable Men On TV 2019" data-pagespeed-lazy-src="https://www.filmibeat.com/img/150x99/2020/09/sidasimharshad-1599223281.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.filmibeat.com/television/news/2020/sidharth-shukla-beats-harshad-chopda-asim-riaz-to-become-times-most-desirable-men-on-tv-2019-303535.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Sidharth Shukla Beats Harshad Chopda &amp; Asim Riaz To Become Times Most Desirable Men On TV 2019</a> </li> <li class="clearfix"> <a href="https://www.goodreturns.in"><span class="timestamp">Finance</span></a> <a href="https://www.goodreturns.in/news/moody-s-downgrades-5-public-sector-banks-cuts-outlook-to-negative-1163299.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Moody's Downgrades 5 Public Sector Banks; Cuts Outlook To 'Negative'" data-pagespeed-lazy-src="https://www.goodreturns.in/img/150x99/2019/08/01-1438416585-banking-1565415683.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.goodreturns.in/news/moody-s-downgrades-5-public-sector-banks-cuts-outlook-to-negative-1163299.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Moody's Downgrades 5 Public Sector Banks; Cuts Outlook To 'Negative'</a> </li> <li class="clearfix"> <a href="https://www.gizbot.com"><span class="timestamp">Technology</span></a> <a href="https://www.gizbot.com/mobile/news/tecno-introduces-camon-16-premier-with-mediatek-helio-g90t-soc-069790.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Tecno Introduces Camon 16 Premier With MediaTek Helio G90T SoC" data-pagespeed-lazy-src="https://www.gizbot.com/img/150x99x100/img/2020/09/tecnoimage-1599223034.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.gizbot.com/mobile/news/tecno-introduces-camon-16-premier-with-mediatek-helio-g90t-soc-069790.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Tecno Introduces Camon 16 Premier With MediaTek Helio G90T SoC</a> </li> <li class="clearfix"> <a href="https://www.oneindia.com"><span class="timestamp">News</span></a> <a href="https://www.oneindia.com/india/kangana-ranaut-has-no-right-to-stay-in-mumbai-maharashtra-minister-3144224.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="'Mumbai-PoK' remark: Kangana Ranaut has no right to stay in Mumbai, says Maharashtra Minister" data-pagespeed-lazy-src="https://www.oneindia.com/img/150x99/2020/01/kangana-ranaut1-1579754833.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.oneindia.com/india/kangana-ranaut-has-no-right-to-stay-in-mumbai-maharashtra-minister-3144224.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">'Mumbai-PoK' remark: Kangana Ranaut has no right to stay in Mumbai, says Maharashtra Minister</a> </li> <li class="clearfix"> <a href="https://www.nativeplanet.com"><span class="timestamp">Travel</span></a> <a href="https://www.nativeplanet.com/travel-guide/places-to-visit-in-maharashtra-in-september-005908.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="10 Most Scenic Places To Visit In Maharashtra In September" data-pagespeed-lazy-src="https://www.nativeplanet.com/img/150x99/2020/09/maharastra-1599222984.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.nativeplanet.com/travel-guide/places-to-visit-in-maharashtra-in-september-005908.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">10 Most Scenic Places To Visit In Maharashtra In September</a> </li> <li class="clearfix"> <a href="https://www.drivespark.com"><span class="timestamp">Automobiles</span></a> <a href="https://www.drivespark.com/two-wheelers/2020/hero-maestro-edge-bs6-110-unveiled-ahead-of-launch-in-india-specs-features-details-032329.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="Hero Maestro Edge 110 BS6 Unveiled Ahead Of Launch In India: Will Rival Honda Activa 6G" data-pagespeed-lazy-src="https://www.drivespark.com/img/150x99/2020/09/hero-maestro-edge-110-bs6-front-profile-1599221729.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.drivespark.com/two-wheelers/2020/hero-maestro-edge-bs6-110-unveiled-ahead-of-launch-in-india-specs-features-details-032329.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">Hero Maestro Edge 110 BS6 Unveiled Ahead Of Launch In India: Will Rival Honda Activa 6G</a> </li> <li class="clearfix"> <a href="https://www.mykhel.com"><span class="timestamp">Sports</span></a> <a href="https://www.mykhel.com/cricket/ipl-2020-harbhajan-singh-reveals-why-he-decided-to-withdraw-from-ipl-13-150941.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="IPL 2020: CSK spinner Harbhajan Singh reveals why he decided to withdraw from IPL 13" data-pagespeed-lazy-src="https://www.mykhel.com/img/150x99/2020/09/mitchell-santner-practice-1599220315.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.mykhel.com/cricket/ipl-2020-harbhajan-singh-reveals-why-he-decided-to-withdraw-from-ipl-13-150941.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">IPL 2020: CSK spinner Harbhajan Singh reveals why he decided to withdraw from IPL 13</a> </li> <li class="clearfix"> <a href="https://www.careerindia.com"><span class="timestamp">Education</span></a> <a href="https://www.careerindia.com/tips/jee-main-dress-code-guidelines-for-female-and-male-on-jee-main-exam-day-027408.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="col-block"><img alt="JEE Main 2020 Dress Code Guidelines For Students" data-pagespeed-lazy-src="https://www.careerindia.com/img/150x99/2020/08/jeemaindresscode-1598889541.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.careerindia.com/tips/jee-main-dress-code-guidelines-for-female-and-male-on-jee-main-exam-day-027408.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Left_Include" class="os-short-text">JEE Main 2020 Dress Code Guidelines For Students</a> </li> </ul> <ul id="bottomLeftVideo"></ul> </div> <div class="database_cat_widget"></div> <div id="adgLeftSticky"><div id="leftSticky" style="display:none;"> <div id="sidebarLeft" style="width:300px;height:600px;overflow:hidden;"> <div class="leftSideOut"><div class="OUTBRAIN" data-src="https://www.boldsky.com/" data-widget-id="AR_3" data-ob-template="GreyniumInformationTechnologiesPvt.Ltd"></div></div> </div> </div></div></div> <div class="oi-article-lt"> <nav> <div class="breadcrump clearfix" id="article-breadcrumb" data-category="Faith Mysticism"> <div> <a href="/"><span>Home</span></a> </div> <span><img src="data:image/jpeg;base64,/9j/4AAQSkZJRgABAQAAAQABAAD/2wBDAAUDBAQEAwUEBAQFBQUGBwwIBwcHBw8LCwkMEQ8SEhEPERETFhwXExQaFRERGCEYGh0dHx8fExciJCIeJBweHx7/2wBDAQUFBQcGBw4ICA4eFBEUHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh7/wAARCAAIAAUDASIAAhEBAxEB/8QAFQABAQAAAAAAAAAAAAAAAAAAAAj/xAAjEAAABAMJAAAAAAAAAAAAAAAAERMVAhIWBAYHFCExMkJj/8QAFAEBAAAAAAAAAAAAAAAAAAAABP/EABkRAAIDAQAAAAAAAAAAAAAAAAEDAAIREv/aAAwDAQACEQMRAD8AprDqq81eKoTb3a0NKhroqx7+fGQ9SPrIAAEtZ1cnBDKXzQDTP//Z" alt="bredcrumb"></span> <div> <a href="/yoga-spirituality/"><span>Yoga spirituality</span></a> </div> <span><img src="data:image/jpeg;base64,/9j/4AAQSkZJRgABAQAAAQABAAD/2wBDAAUDBAQEAwUEBAQFBQUGBwwIBwcHBw8LCwkMEQ8SEhEPERETFhwXExQaFRERGCEYGh0dHx8fExciJCIeJBweHx7/2wBDAQUFBQcGBw4ICA4eFBEUHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh7/wAARCAAIAAUDASIAAhEBAxEB/8QAFQABAQAAAAAAAAAAAAAAAAAAAAj/xAAjEAAABAMJAAAAAAAAAAAAAAAAERMVAhIWBAYHFCExMkJj/8QAFAEBAAAAAAAAAAAAAAAAAAAABP/EABkRAAIDAQAAAAAAAAAAAAAAAAEDAAIREv/aAAwDAQACEQMRAD8AprDqq81eKoTb3a0NKhroqx7+fGQ9SPrIAAEtZ1cnBDKXzQDTP//Z" alt="bredcrumb"></span> <div> <a href="/yoga-spirituality/faith-mysticism/"><span>Faith mysticism</span></a> </div> </div> </nav> <header> <h1 class="articleheading">Teachers’ Day 2020: Some Top Gurus And Saints In Hindu Mythology</h1> <div class="io-category" style="display: none">Faith Mysticism</div> <div class="io-author" style="display: none">oi-Prerna Aditi</div> <div class="date_time date-time" data-author="Prerna Aditi"><div class="author-profile written-by">By <a rel="author" href="/authors/prerna-aditi.html" title="Profile of Prerna Aditi " target="_blank"><strong>Prerna Aditi</strong></a></div> <span> <time datetime="2020-09-04T18:30:00+05:30" itemprop="datePublished">
on September 4, 2020
</time> </span> </div> </header> <p>A teacher plays one of the most important roles in a child's life. He/she can shape the life and future of a child through teachings. Perhaps therefore, teachers are considered no less than God. To express our gratitude to teachers and respect their efforts, we celebrate Teachers' Day every year on 5 September.</p> <p><strong></strong></p> <div class="vucato-shop c2"><strong></strong> <div class="big_center_img" data-cl-cnt="0" data-cnt-t="0" data-gal-src="/img/2020/09/gurussaints-1599222005.jpg"><strong></strong> <div><strong><a class="imgClSlider" href="javascript:void(0);"> <figure><strong><img src="/img/2020/09/gurussaints-1599222005.jpg" class="image_listical c1" alt="Gurus And Saints In Hindu Mythology" title="Gurus And Saints In Hindu Mythology" data-cl-slideshow="" data-cl-title="Gurus And Saints In Hindu Mythology" data-cl-description="" data-cl-imageid="134531-0"/></strong></figure> </a></strong></div> </div> </div> <div class="promote_oi_articles"></div> <div class='cmscontent-article1 inhouse-content' id='cmscontent-article1' data-zoneid='{"backfill":"69","inhouse":"63"}' data-reviveid='{"backfill":"9de4f035bc8106094a8824fc0cfb6de3","inhouse":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div class='refreshInarticleAd listical-ad-left c3' data-slno='0' data-refreshed='1' data-status='false' data-adval="0"> <div id='div-gpt-ad-1468312626651-0' class='oi-axt' data-elementid='4'></div> </div> </div> <p>This Teachers' Day while you remember your teachers and thank them for making your life, take a moment to read about some of the spiritual teachers, Gurus and saints in Hindu Mythology. Scroll down the article to read about the below-mentioned people.</p> <p><span class="deepLinkPromo"><a href="https://www.boldsky.com/yoga-spirituality/faith-mysticism/friendship-day-iconic-friendships-from-indian-mythology-134114.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Deep-Links"><img class="deepLinkPromoImg" data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/07/krishnaandarjuna-1595941080.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/>Friendship Day 2020: Some Iconic Stories About True Friendship In Indian Mythology</a></span></p> <div id="first_slide_info"></div> <div id="slide_container"> <div class="c2"></div> <div id="frame-fancybox-overlay" class="overlay-fixed c4"></div> <div id="mainContent"> <style> <![CDATA[
.photo-feature-table tr:nth-child(odd) { background-color:#fff!important; }
.photo-feature-table tr:nth-child(even)    { background-color:#fff!important;}
]]> </style> <div id="listicalSliderDiv" class="c6"> <div id="slider0" class="listicalSliderContainer" data-slno="1" data-pagetype="0" data-url="articlecontent-pf223935-134531" data-gal-headline="Adi Shankaracharya" data-gal-desc="Adi Shankaracharya was one of the top mystic Gurus in Hindu mythology. He was a great philosopher and theologian who spread the knowledge..." data-gal-src="www.boldsky.com/img/600x100/2020/09/adishankaracharya-1599222039.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/adishankaracharya-1599222039.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <h2 class="para_head">Adi Shankaracharya</h2> <p>Adi Shankaracharya was one of the top mystic Gurus in Hindu mythology. He was a great philosopher and theologian who spread the knowledge of Advaita Vedanta during the 8th century. He is also known to be one of the pioneers in Hinduism. The four important Mathas in Hinduism is because of his efforts and teachings.</p> </div> <div id="slider1" class="listicalSliderContainer" data-slno="2" data-pagetype="0" data-url="articlecontent-pf223936-134531" data-gal-headline="Maharishi Valmiki" data-gal-desc="Maharishi Valmiki is said to be the pioneer of Sanskrit literature. One of his famous works includes the original version of Ramayana. He..." data-gal-src="www.boldsky.com/img/600x100/2020/09/maharishivalmiki-1599222067.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/maharishivalmiki-1599222067.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <h2 class="para_head">Maharishi Valmiki</h2> <p>Maharishi Valmiki is said to be the pioneer of Sanskrit literature. One of his famous works includes the original version of Ramayana. He is often referred to as Adi Kavi, the first poet. During the early years of his life, he was a dacoit but after meeting a learned sage, he went on to penance and became one of the greatest sages of all time.</p> </div> <div id="slider2" class="listicalSliderContainer" data-slno="3" data-pagetype="0" data-url="articlecontent-pf223937-134531" data-gal-headline="Guru Vashishth" data-gal-desc="Guru Vashishth is known to be one of the greatest Gurus in Hinduism. He is believed to be the mentor and teacher of Ikshvaku Kings, inclu..." data-gal-src="www.boldsky.com/img/600x100/2020/09/guruvashishth-1599222059.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/guruvashishth-1599222059.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <div class="cmscontent-article2 inhouse-content" id="cmscontent-article2" data-zoneid='{"inhouse":63,"backfill":69}' data-reviveid='{"inhouse":"9de4f035bc8106094a8824fc0cfb6de3","backfill":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div class="oiad listical-ad-left oi-axt c5" id='div-gpt-ad-1468312758033-0' data-exec="0" data-adval="0" data-elementid="5"></div> </div> <h2 class="para_head">Guru Vashishth</h2> <p>Guru Vashishth is known to be one of the greatest Gurus in Hinduism. He is believed to be the mentor and teacher of Ikshvaku Kings, including Lord Rama and his brothers. As per Hindu mythology, he was the preceptor of Manu, the first man on earth. Many of his teachings are described in the Vedas and Ramayana.</p> </div> <div id="slider3" class="listicalSliderContainer" data-slno="4" data-pagetype="0" data-url="articlecontent-pf223938-134531" data-gal-headline="Dronacharya" data-gal-desc="Dronacharya is said to be the Guru of Pandavas and Kauravas in Mahabharata. He was the one who gave teachings to Arjuna, one of the Panda..." data-gal-src="www.boldsky.com/img/600x100/2020/09/dronacharya-1599222050.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/dronacharya-1599222050.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <h2 class="para_head">Dronacharya</h2> <p>Dronacharya is said to be the Guru of Pandavas and Kauravas in Mahabharata. He was the one who gave teachings to Arjuna, one of the Pandavas. Due to his teachings, the princes of both Pandavas and Kauravas clan became the master of all forms of warfare. They excelled in scholarly knowledge and various arts. He was the friend of King Drupad, the father of Draupadi who married Pandavas.</p> </div> <div id="slider4" class="listicalSliderContainer" data-slno="5" data-pagetype="0" data-url="articlecontent-pf223939-134531" data-gal-headline="Kavi Surdas" data-gal-desc="Kavi Surdas was a blind poet who wrote and sang devotional poems for Lord Krishna. He not only wrote songs and poems in praise of Lord Kr..." data-gal-src="www.boldsky.com/img/600x100/2020/09/kavisurdas-1599222063.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/kavisurdas-1599222063.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <div id='adg-in-art'></div> <h2 class="para_head">Kavi Surdas</h2> <p>Kavi Surdas was a blind poet who wrote and sang devotional poems for Lord Krishna. He not only wrote songs and poems in praise of Lord Krishna but also shared the teachings of Lord Krishna. He used to write the poems and songs in Braj Bhasha which was spoken by Lord Krishna himself. Through his songs and poems, he beautifully described the divine love between Lord Krishna and Goddess Radha.</p> </div> <div id="slider5" class="listicalSliderContainer" data-slno="6" data-pagetype="0" data-url="articlecontent-pf223940-134531" data-gal-headline="Guru Ravidas" data-gal-desc="Guru Ravidas also known as Sant Ravidas, was a mystic Guru who played a significant role during the Bhakti movement. As a spiritual figur..." data-gal-src="www.boldsky.com/img/600x100/2020/09/gururavidas-1599222054.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/gururavidas-1599222054.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <h2 class="para_head">Guru Ravidas</h2> <p>Guru Ravidas also known as Sant Ravidas, was a mystic Guru who played a significant role during the Bhakti movement. As a spiritual figure, social reformer and poet-saint, he inspired many people through his teachings. He belonged to a family of the leather-working community, considered to be untouchables. But Guru Ravidas became the disciple of a Brahman named Ramananda. He later went to become one of the greatest spiritual teachers in Hinduism.</p> </div> <div id="slider6" class="listicalSliderContainer" data-slno="7" data-pagetype="0" data-url="articlecontent-pf223941-134531" data-gal-headline="Mirabai" data-gal-desc="Mirabai was an ardent devotee of Lord Krishna and also a mystic poet who existed during the 16th century. In Hinduism, Mirabai is conside..." data-gal-src="www.boldsky.com/img/600x100/2020/09/meerabhai-1599222073.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/meerabhai-1599222073.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <div class="refreshInarticleAd listical-ad-left" data-slno="0" data-refreshed="0" data-status="false" data-adval="1"></div> <h2 class="para_head">Mirabai</h2> <p>Mirabai was an ardent devotee of Lord Krishna and also a mystic poet who existed during the 16th century. In Hinduism, Mirabai is considered to be a saintly woman who dedicated her entire life to the devotion of Lord Krishna. She was deliberately married to Bhoj Raj, the crown prince of Mewar, Rajasthan. But Mirabai was always engrossed in the worship of Lord Krishna. After the demise of her husband, father and father-in-law, Vikram Singh, the new king of Mewar tried to kill Mirabai through several attempts but each time she survived miraculously.</p> </div> <div id="slider7" class="listicalSliderContainer" data-slno="8" data-pagetype="0" data-url="articlecontent-pf223942-134531" data-gal-headline="Chaitanya Mahaprabhu" data-gal-desc="Chaitanya Mahaprabhu is another scholarly saint and spiritual teacher in Hinduism. Devotees of Chaitanya Mahaprabhu consider him the inca..." data-gal-src="www.boldsky.com/img/600x100/2020/09/chaitanyamahaprabhu-1599222045.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/chaitanyamahaprabhu-1599222045.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <h2 class="para_head">Chaitanya Mahaprabhu</h2> <p>Chaitanya Mahaprabhu is another scholarly saint and spiritual teacher in Hinduism. Devotees of Chaitanya Mahaprabhu consider him the incarnation of Lord Krishna. He worshipped Lord Krishna by singing ecstatic songs and also danced while singing those devotional songs. He propounded the Vedantic Philosophy of Achintya Abheda Bheda, a school of Vedanta established by Mahaprabhu himself.</p> </div> <div id="slider8" class="listicalSliderContainer" data-slno="9" data-pagetype="0" data-url="articlecontent-pf223943-134531" data-gal-headline="Ramakrishna Paramhansa" data-gal-desc="Ramakrishna Paramahansa who was born as Gangadhar Chattopadhyay was a saint, scholar, teacher and religious leader from 1836 to 1886. It ..." data-gal-src="www.boldsky.com/img/600x100/2020/09/ramakrishnaparamhansa-1599222078.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/ramakrishnaparamhansa-1599222078.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <div class="refreshInarticleAd listical-ad-right" data-slno="0" data-refreshed="0" data-status="false" data-adval="1"></div> <h2 class="para_head">Ramakrishna Paramhansa</h2> <p>Ramakrishna Paramahansa who was born as Gangadhar Chattopadhyay was a saint, scholar, teacher and religious leader from 1836 to 1886. It is said that he experienced spiritual ecstasy at a very young age and was a devotee of Goddess Kali, Advaita Vedant, Tantra and Bhakti. He was the mentor to Swami Dayanand Saraswati for some time. He also taught and guided Swami Vivekananda. Both he and his wife Sarada Devi were deeply involved in Tantra and Bhakti.</p> </div> <div id="slider9" class="listicalSliderContainer" data-slno="10" data-pagetype="0" data-url="articlecontent-pf223944-134531" data-gal-headline="Swami Dayanand Saraswati" data-gal-desc="Swami Dayanand Saraswati, the founder of Arya Samaj and DAV College was a great social reformer, spiritual leader, teacher and yogi. Even..." data-gal-src="www.boldsky.com/img/600x100/2020/09/swamidayanandsaraswati-1599222082.jpg"> <section class="listicalSliderContent"> <figure><img src="/img/2020/09/swamidayanandsaraswati-1599222082.jpg" alt="Array" title="" class="sliderImg image_listical"/></figure> </section> <div class="refreshInarticleAd listical-ad-left" data-slno="0" data-refreshed="0" data-status="false" data-adval="1"></div> <h2 class="para_head">Swami Dayanand Saraswati</h2> <p>Swami Dayanand Saraswati, the founder of Arya Samaj and DAV College was a great social reformer, spiritual leader, teacher and yogi. Even today people belonging to the Arya Samaj community follow his teachings. He is considered one of the makers of Modern India. He denounced idol worship prevalent in Hinduism and inspired people to the belief that God has no shape. According to him, people should worship God in his true and divine form. He revived the Vedic knowledge and teachings. He emphasised on the doctrine of Reincarnation and Karma.</p> <p><strong>Image source: <a href="https://english.newstracklive.com/news/birthday-special--swami-dayanand-saraswati-founder-of-arya-samaj-sc1-nu-1001681-1.htm" target="_blank">News Tracker</a></strong></p><div id='div-gpt-ad-1527055403211-0' class='viroolVideo'></div> </div> </div> </div> <div class="c2"></div> </div> <div id="endofcontent"></div> <div class="slider-article-list-wrap"> <div class="slider-widget-next"><a href="/topic/teachers%E2%80%99-day-2020/?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic"> <h2 class="widgetHeading">More <span>TEACHERS’ DAY 2020</span> News <i></i></h2> </a></div> <div class="slider-article-lists clearfix"> <ul> <li> <div class="slider-article-thumbimg"><a href="/insync/life/teachers-day-wishes-quotes-images-whatsapp-status-messages-134523.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2020/09/xhappy-teachers-day--1599198899.jpg.pagespeed.ic.SgT4Ro6WYC.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/insync/life/teachers-day-wishes-quotes-images-whatsapp-status-messages-134523.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Teachers’ Day 2020: Heartfelt Quotes, Messages And Wishes To Share On This Day</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/beauty/make-up-tips/makeup-tips-for-teachers-129794.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2019/09/xteachers-1567666246.png.pagespeed.ic.oUlJ-Z3t9F.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/beauty/make-up-tips/makeup-tips-for-teachers-129794.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Teachers’ Day 2019: Here Are A Few Simple And Effective Make-up Tips For Teachers</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/insync/pulse/teachers-day-2019-google-uses-animated-doodle-to-honour-indian-educators-129792.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2019/09/xgoogledoodle-1567663921.jpg.pagespeed.ic.OSV7ar9taR.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/insync/pulse/teachers-day-2019-google-uses-animated-doodle-to-honour-indian-educators-129792.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Teachers’ Day 2019: Google Uses Animated Doodle To Honour The Educators Of India</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/relationship/beyond-love/benefits-of-having-healthy-student-teacher-relationship-129778.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2019/09/xparent-teacher-1-1567592436.jpg.pagespeed.ic.kAnoIHQ4nL.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/relationship/beyond-love/benefits-of-having-healthy-student-teacher-relationship-129778.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Teachers' Day: Why Teachers And Students Should Have A Healthy Bond</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/relationship/parents-and-children/how-students-and-teachers-can-develop-healthy-student-teacher-relationship-129759.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2019/09/xstudentteacher-1567508834.jpg.pagespeed.ic.Lb2j2cKoOy.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/relationship/parents-and-children/how-students-and-teachers-can-develop-healthy-student-teacher-relationship-129759.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Teachers Day 2019: How Students And Teachers Can Develop A Healthy Student-Teacher Relationship</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/yoga-spirituality/festivals/2019/guru-purnima-date-time-and-significance-129039.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2019/07/xhappygurupurnimafinal-1563190933.jpg.pagespeed.ic.edIbp7NM8W.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/yoga-spirituality/festivals/2019/guru-purnima-date-time-and-significance-129039.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Guru Purnima 2019: Date, Time And Significance</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/insync/life/2018/teacher-s-day-quotes-by-famous-personalities-and-its-meaning-125398.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2018/09/xabdulkalam-1536129421.jpg.pagespeed.ic.hHxznvRFUS.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/insync/life/2018/teacher-s-day-quotes-by-famous-personalities-and-its-meaning-125398.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Best Teacher’s Day Quotes By Famous Personalities</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/insync/life/2018/things-that-you-need-know-sarvepalli-radhakrishnan-125394.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2018/09/xradhakrishnan-04-1472973162-1536087491.jpg.pagespeed.ic.BAnxeb0-IC.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/insync/life/2018/things-that-you-need-know-sarvepalli-radhakrishnan-125394.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Teachers Day 2019: Interesting Facts About Sarvepalli Radhakrishnan</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/insync/life/2017/famous-teachers-from-history-116866.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2017/09/xcollage-01-1504269104.jpg.pagespeed.ic.lK1Lrr4KPa.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/insync/life/2017/famous-teachers-from-history-116866.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Famous Teachers From History</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/insync/pulse/2014/teachers-day-special-why-teaching-is-the-best-profession-045964.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2014/09/x05-teacher1.jpg.pagespeed.ic.CM718MBsUx.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/insync/pulse/2014/teachers-day-special-why-teaching-is-the-best-profession-045964.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Teachers Day 2019: Here's Why Teaching Is The Best Profession</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/insync/life/2014/reasons-why-teachers-rock-045926.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2017/09/x1-04-1504509608.jpg.pagespeed.ic.1jM0sMuzBB.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/insync/life/2014/reasons-why-teachers-rock-045926.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">Reasons Why Teachers Rock</a></div> </li> <li> <div class="slider-article-thumbimg"><a href="/yoga-spirituality/thought/2019/the-story-of-eklavya-and-dronacharya-127901.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider"><img src="https://www.boldsky.com/img/175x85x131/2019/03/xeklavyacoveimage-1553499539.jpg.pagespeed.ic.eWzTMVroUq.jpg" alt=""/></a></div> <div class="slider-article-title"><a href="/yoga-spirituality/thought/2019/the-story-of-eklavya-and-dronacharya-127901.html?utm_medium=Desktop&utm_source=BS-EN&utm_campaign=Similar-Topic-Slider">The Story Of Eklavya And Guru Dronacharya</a></div> </li> </ul> </div> </div> <div id="bottom-single-video-block"></div> <style type="text/css">
	.notifications-block {width: 300px;padding: 30px 0;margin: 0 auto;}
.allow-notifications {
    font-size: 16px;
    height: 45px;
    line-height: 45px;
    padding: 0;
    background: #000;
    color: #ffffff;
    text-transform: uppercase;
    text-align: center;
    padding-right: 50px;
    position: relative;
    cursor: pointer;
    display: none;
}
.allow-notifications i {position: absolute;right: 5px;    top: 5px;width: 35px;height: 35px;color: #000;font-size: 32px;}
.already-subscribed {
    font-size: 14px;
    height: 45px;
    line-height: 45px;
    padding: 0;
    background: #1b74e9;
    color: #ffffff;
    text-align: center;
    padding-right: 50px;
    position: relative;
    display: none;
}
.notification-settings-link {font-size: 14px;color: #0066cc;padding: 30px 0 0 0;font-weight: 600;text-align: center;display: none;}
.notification-settings-link a {color: #0066cc;}
.notification-settings-link a i {vertical-align: middle;}
.already-subscribed i {position: absolute;right: 5px;    top: 5px;width: 35px;height: 35px;color: #000;font-size: 32px;}
.notf-sub .already-subscribed, .notf-sub .notification-settings-link {display: block;}
.notf-sub .allow-notifications {display: none;}
.bell-icons {
    width: 40px;
    height: 36px;
    background: #fff url(/images/bell-icon.svg) no-repeat center;
    background-size: 60%;
    display: block;
    position: absolute;
    right: 2px;
    top: 2px;
}
.tick-icons {
    width: 40px;
    height: 36px;
    background: #fff url(/images/tick-icon.png) no-repeat center;
    background-size: 60%;
    display: block;
    position: absolute;
    right: 2px;
    top: 2px;
}
.notification-outerblock {
	background: #f2f2f2;
    padding: 10px;
    margin: 10px auto;
    float: left;
    width: 600px;
    box-sizing: border-box;
}
.breaking-newstext {font-size: 16px;text-align: center;text-transform: uppercase;float: left;margin: 15px 10px;width: 240px;}
.notifications-block {padding: 10px;float: left;clear: none;}
</style> <div class="notification-outerblock clearfix" id="notification-articleblock" style="display: none;"> <div class="breaking-newstext">
GET THE BEST BOLDSKY STORIES!
</div> <div class="notifications-block clearfix"> <div class="allow-notifications" id="allow-notifications">
Allow Notifications <i class="bell-icons"></i> </div> <div class="already-subscribed" id="already-subscribed">
You have already subscribed <i class="tick-icons"></i> </div> </div> </div> <div class="comments-wrap" style="display:none;"> <span id="text_change"><a class="vuuk_num" id="vuuk_num" data="vuukle-count" href="#vuukle-comments"></a><a href="#vuukle-comments"> Comments </a><i class="comments-icon"></i></span> </div> </div> </div> </div> </article> <div class="related_content_block" id="related_content_display"> </div> <div style="width:97%;"> <div id='div_82997313894793' style="padding-top:10px;clear:both;"> <div id="belowContent" style="clear:both;"> <div class="belowConOut"><div class="OUTBRAIN" data-src="https://www.boldsky.com/" data-widget-id="AR_1" data-ob-template="GreyniumInformationTechnologiesPvt.Ltd"></div></div> </div> </div> </div> <div id="impulserWidget"></div> <div></div> <div id="tag-container" class="tags" data-tags="teachers’ day 2020, teachers’ day, teachers, guru" data-eng-tags=" teachers, guru"> <div id="inread"></div> <div style="clear: both;"></div> <span class="tags_head">Read more about: </span> <a title="teachers’ day 2020" href="/topic/teachers’-day-2020">teachers’ day 2020</a> <a title="teachers’ day" href="/topic/teachers’-day">teachers’ day</a> <a title="teachers" href="/topic/teachers">teachers</a> <a title="guru" href="/topic/guru">guru</a><div style="clear: both; padding-bottom: 5px;"></div> </div> <div class="story_time">Story first published: Friday, September 4, 2020, 18:30 [IST]</div> <div class="dayindex_link">
Other articles published on <a href="/2020/09/04/">Sep 4, 2020</a> </div> </div> </div> <div class="comments_div"> <div style="width:97%;"><div id="vuukle-comments"> </div> </div> <div class="cmscontent-bottom inhouse-content" style="display:block;" id="cmscontent-bottom" data-zoneId='{"backfill":"69","inhouse":"63"}' data-reviveId='{"backfill":"9de4f035bc8106094a8824fc0cfb6de3","inhouse":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div id="div-gpt-ad-1506054776114-0" data-exec=0 data-adval=0 data-elementid="6" class="oiad oi-axt" style="padding-bottom:10px;clear:both;"></div> </div> </div> </div> <div id="article_ad"> <div id="article_page_ad" style="display: none;"> <div class="photos-featured-posts"> <ul> <li> <a href="/health/apollo-hospitals-saves-georgian-nationals-leg-through-timely-treatment-134498.html" target="_blank"> <img data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/09/xapollo-1598963790.jpg.pagespeed.ic.n4qN81MWHx.jpg" alt="Chennai Hospital Saves Georgian National’s Leg Through Timely Treatment" class="cinelist-thumbimg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/> </a> <h5 class="postTitle"><a href="/health/apollo-hospitals-saves-georgian-nationals-leg-through-timely-treatment-134498.html" target="_blank">Chennai Hospital Saves Georgian National’s Leg Through Timely Treatment</a></h5> <div class="clear"></div> </li> <li> <a href="/fashion/trends/julianne-moore-s-bracelets-and-white-outfit-look-on-instagram-134495.html" target="_blank"> <img data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/09/x04-1598964344.jpg.pagespeed.ic.qDEqQexId2.jpg" alt="Yes, We Liked Julianne Moore’s White Lace Outfit But Her Serpentine Bracelets Are What We Want " class="cinelist-thumbimg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/> </a> <h5 class="postTitle"><a href="/fashion/trends/julianne-moore-s-bracelets-and-white-outfit-look-on-instagram-134495.html" target="_blank">Yes, We Liked Julianne Moore’s White Lace Outfit But Her Serpentine Bracelets Are What We Want </a></h5> <div class="clear"></div> </li> <li> <a href="/beauty/make-up-tips/hina-khan-s-stunning-neon-yellow-make-up-134487.html" target="_blank"> <img data-pagespeed-lazy-src="https://www.boldsky.com/img/2020/09/xhina-1598941585.jpg.pagespeed.ic.p1HfYydL1f.jpg" alt="Hina Khan’s Neon Yellow Make-up Will Lift Your Spirits Instantly" class="cinelist-thumbimg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/> </a> <h5 class="postTitle"><a href="/beauty/make-up-tips/hina-khan-s-stunning-neon-yellow-make-up-134487.html" target="_blank">Hina Khan’s Neon Yellow Make-up Will Lift Your Spirits Instantly</a></h5> <div class="clear"></div> </li> </ul> <div class="photos-featured-posts-text">Featured Posts</div> </div> </div> </div> <div class="content_right"> <div style="min-height: 250px; margin-bottom: 10px;"> <div class="cmscontent-right1 inhouse-content" style="display:block;" id="cmscontent-right1" data-zoneId='{"backfill":"69","inhouse":"63"}' data-reviveId='{"backfill":"9de4f035bc8106094a8824fc0cfb6de3","inhouse":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div data-cb-ad-id="living-island" class="ad"> <div id='div-gpt-ad-1384229845424-7' data-exec=0 data-adval=0 data-elementid="1" class="oiad oi-axt"></div> </div> </div> </div> <div id="VTN_CB_300x250"></div> <div class="newsletter_form oi-dailyalerts" style="clear: both;"> <div class="searchText">Subscribe Newsletter</div> <form target="_blank" class="nospace" action="https://app5.saymails.com/cgi-bin/useradd.pl" method="post" name="formNewsLetter"> <div class="newsletter_form_name"> <input type="hidden" name="city" id="newsletter_city"/> <input type="hidden" name="country" id="newsletter_country"/> <input type="hidden" name="dbname1" value="b25laW5kaWE="/> <input type="hidden" name="listname1" value="Ym9sZHNreQ=="/> <input type="hidden" name="action1"> </div> <div class="newsletter_form_name"> <input type="text" class="newsletterTextbox" maxlength="100" size="15" placeholder="Enter Email ID for daily updates" name="email" id="email"> </div> <div class="newsletter_form_submit"> <input type="image" src="data:image/jpeg;base64,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" alt="Subscribe" onclick="return postformById('useradd',this.form);" class="subscribeBtn"/> </div> </form></div> <div id="iksWidget" style="padding-top: 10px; clear: both;"></div> <style>
.sixtysec-rightblock ul {
    padding: 0;
    margin: 0;
}
.sixtysec-left {
    width: 100px;
    height: 75px;
    float: left;
}
.sixtysec-rightblock {
    width: 297px;
    border: 1px solid #7b7b7b;
    border-bottom: none;
    margin: 10px 0;
}
.sixtysec-rightblock ul li {
    list-style-type: none;
    padding: 8px;
    border-bottom: 1px solid #7b7b7b;
    padding-bottom: 8px;
    position: relative;
}
.sixtysec-rightblock ul li a {
    text-decoration: none !important;
}
.sixtysec-right {
    margin-left: 112px;
    font-size: 14px;
    color: #000;
    line-height: 19px;
    text-decoration: none;
}
</style> <div class="sixtysec-rightblock" style="margin-bottom: 10px;"> <ul id="right-native-ad"> </ul> </div> <div class="right_include_links"> <div class="non-friendly-scatter"> <div id="artRight"></div> <div id="sidebarRight"> <div class="rightSideOut"><div class="OUTBRAIN" data-src="https://www.boldsky.com/" data-widget-id="AR_2" data-ob-template="GreyniumInformationTechnologiesPvt.Ltd"></div></div> </div> </div> <div class="cmscontent-right2 inhouse-content" id="cmscontent-right2" data-zoneid='{"inhouse":63,"backfill":69}' data-reviveid='{"inhouse":"9de4f035bc8106094a8824fc0cfb6de3","backfill":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div id='div-gpt-ad-1384229845424-1' data-exec=0 data-adval=0 data-elementid="2" class="oiad oi-axt" style="padding: 10px 0;"></div> </div> <div id="fwn_right_videos" style="padding:10px 0;"></div> <div class="bottom_island_ad"> <div style="padding-top: 10px;"> </div> <div id="crowdy-value" data-crowdynews-widget="Boldsky_home-vertical" style="height:850px;"></div> <div style="padding-top:10px;"></div> <div id="insticator-container" style="height:600px;"><div id="div-insticator-ad-1"></div><div id="insticator-embed"></div><div id="div-insticator-ad-2"></div></div> <div id="div_24550486768810" style="padding-top: 15px;height:560px;"></div> </div> <div id="rightSticky" style="clear: both;height:600px;"> <div id="div-gpt-ad-1384229845424-2" data-exec=0 data-adval=0 data-elementid="7" class="oiad oi-axt" style="clear: both;min-height:600px;"></div> </div> </div> </div> </div> <div id="bottom_content"></div> <div id="fullwrapper_footer" class="io-article-footer">
&nbsp;
<div style="clear: both;"></div> <div class="giz-overlay"></div> <link rel="stylesheet" href="/common/adaptive/css/font-awesome.min.css?v=2"/> <link rel="stylesheet" href="/common/adaptive/css/footer-only.css?v=5"/> <footer id="footerMain"> <div class="clearfix"> <div class="site-logo"> <a href="/" class="oneindia-logo"><img data-pagespeed-lazy-src="/images/logos/boldsky-logo-on1.svg" alt="Boldsky" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> </div> <div class="site-outerblock"> <div class="site-languages"> <div class="footer-heading"><span></span>Boldsky in Other Languages</div> <ul style="padding:0;margin:0;"> <li style="padding-bottom: 0;"><a href="https://hindi.boldsky.com/" style="line-height: 8px;">हिन्दी <i class="fa fa-angle-right"></i></a></li> <li style="padding-bottom: 0;"><a href="https://kannada.boldsky.com/" class="lang-kannada" style="line-height: 10px;">ಕನ್ನಡ <i class="fa fa-angle-right"></i></a></li> <li style="padding-bottom: 0;"><a href="https://malayalam.boldsky.com/" class="lang-malayalam" style="line-height: 9px;">മലയാളം <i class="fa fa-angle-right"></i></a></li> <li style="padding-bottom: 0;"><a href="https://tamil.boldsky.com/" class="lang-tamil" style="line-height: 8px;">தமிழ் <i class="fa fa-angle-right"></i></a></li> <li style="padding-bottom: 0;"><a href="https://telugu.boldsky.com/" class="lang-telugu" style="line-height: 8px;">తెలుగు <i class="fa fa-angle-right"></i></a></li> <li style="padding-bottom: 0;"><a href="https://bengali.boldsky.com/" class="lang-bengali" style="line-height: 14px;">বাংলা <i class="fa fa-angle-right"></i></a></li> <li style="padding-bottom: 0;"><a href="https://gujarati.boldsky.com/" class="lang-gujarati" style="line-height: 11px;">ગુજરાતી <i class="fa fa-angle-right"></i></a></li> </ul> </div> <div class="site-links" itemscope itemtype="https://www.schema.org/SiteNavigationElement"> <div class="footer-heading"><span></span>Explore Boldsky</div> <ul style="padding:0;margin:0;"> <li><a href="/health/" itemprop="url"><i class="fa fa-angle-right"></i> <span itemprop="name">Health</span></a></li> <li><a href="/beauty/" itemprop="url"><i class="fa fa-angle-right"></i> <span itemprop="name">Beauty</span></a></li> <li><a href="/insync/" itemprop="url"><i class="fa fa-angle-right"></i> <span itemprop="name">Insync</span></a></li> <li><a href="/cookery/" itemprop="url"><i class="fa fa-angle-right"></i> <span itemprop="name">Cookery</span></a></li> <li><a href="/fashion/" itemprop="url"><i class="fa fa-angle-right"></i> <span itemprop="name">Fashion</span></a></li> <li><a href="/relationship/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name"> Relationship</span></a></li> <li><a href="/home-n-garden/" itemprop="url"><i class="fa fa-angle-right"></i> <span itemprop="name">Home-n-Garden</span></a></li> <li><a href="/yoga-spirituality/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Yoga-Spirituality</span></a></li> <li><a href="/pregnancy-parenting/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Pregnancy-Parenting</span></a></li> </ul> </div> <div class="other-child-sites"> <div class="footer-heading"><span></span>Other Greynium Sites</div> <ul style="padding:0;margin:0;"> <li><a href="https://www.filmibeat.com/" rel="nofollow" class="filmibeat-logo"><span>Filmibeat</span></a></li> <li><a href="https://www.drivespark.com/" rel="nofollow" class="drivespark-logo"><span>Drivespark</span></a></li> <li><a href="https://www.gizbot.com/" rel="nofollow" class="gizbot-logo"><span>Gizbot</span></a></li> <li><a href="https://www.goodreturns.in/" rel="nofollow" class="goodreturns-logo"><span>Goodreturns</span></a></li> <li><a href="https://www.nativeplanet.com/" rel="nofollow" class="nativeplanet-logo"><span>Native Planet</span></a></li> <li><a href="https://www.careerindia.com/" rel="nofollow" class="careerindia-logo"><span>Careerindia</span></a></li> <li><a href="https://www.click.in/" rel="nofollow" class="clickin-logo"><span>Clickin</span></a></li> </ul> </div> <div class="other-site-details"> <div class="footer-heading"><span></span>Follow Boldsky</div> <div class="footer-bottom-border"> <div class="footer-social-links"> <a href="https://www.facebook.com/boldsky.com" rel="nofollow" class="fb-icon"> <i class="fa fa-facebook"></i></a> <a href="https://twitter.com/Boldsky" rel="nofollow" class="tw-icon"> <i class="fa fa-twitter"></i></a> <a href="https://www.youtube.com/channel/UCp0PDmU9L_rqiD4nDH-P2Tg" class="yt-icon"></a> </div> </div> <div class="footer-notification-block" id="footerNotification" style="display: none;"> <div class="footer-subheading">Get Oneindia Alerts</div> <div class="get-notifications"> <a href="https://secure.oneindia.com/notification/index.html" rel="nofollow" class="btn">Get Push Notifications</a> </div> </div> </div> <div class="clear"></div> </div> <div class="footer-links"> <a href="/aboutus.html">About Us</a> | <a href="https://www.greynium.com/terms-of-service" rel="nofollow">Terms of Service</a> | <a href="https://www.greynium.com/privacy-policy" rel="nofollow">Privacy Policy</a> | <a href="/rss/">RSS</a> | <a href="/contact.html">Contact Us</a> | <a href="https://www.greynium.com/feedback" rel="nofollow">Feedback</a> | <a href="/sitemap/">Sitemap</a> | <a href="/common/cookies/change-cookie-settings.html" target="_blank">Cookie Policy</a> </div> <div class="copyright-text">&copy; <span id="curYear"></span> Greynium Information Technologies Pvt. Ltd. All Rights Reserved.</div> </div> </footer> <script type="text/javascript" data-pagespeed-no-defer>pagespeed.lazyLoadImages.overrideAttributeFunctions();</script><script type="text/javascript">function setUserCookie(name,value,expires,path,domain,secure){var chkcookiepolicy=getUserCookie('cookiePolicy');console.log(chkcookiepolicy);if(chkcookiepolicy!=0){var today=new Date();today.setTime(today.getTime());if(expires){expires=expires*1000*60*60;}var expires_date=new Date(today.getTime()+(expires));document.cookie=name+'='+escape(value)+((expires)?';expires='+expires_date.toGMTString():'')+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+((secure)?';secure':'');}}function deleteUserCookie(name,path,domain){if(getCookie(name))document.cookie=name+'='+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+';expires=Thu, 01-Jan-1970 00:00:01 GMT';}function checkUserCookie(cookie_name){var location_details=getUserCookie(cookie_name);if(location_details==null||location_details==""){return false;}else if(location_details!=""){return true;}}function getUserCookie(c_name){var c_value=document.cookie;var c_start=c_value.indexOf(" "+c_name+"=");if(c_start==-1){c_start=c_value.indexOf(c_name+"=");}if(c_start==-1){c_value=null;}else{c_start=c_value.indexOf("=",c_start)+1;var c_end=c_value.indexOf(";",c_start);if(c_end==-1){c_end=c_value.length;}c_value=unescape(c_value.substring(c_start,c_end));}return c_value;}</script> <style type="text/css">
#notify-subscribe {
    font-weight: bold;
    color: #0066cc;
    text-decoration: underline;
    cursor: pointer;
}
</style> <link type="text/css" rel="stylesheet" href="/common/min/?b=common/adaptive/css&f=desktop-notification.css&v=17"/> <div class="notf-overlay"></div> <div class="instant-updates-bottom" id="oiNotification"> <div class="instant-updates-mid"> <div class="instant-updates-left" id="enable-btn"> <div class="instant-updates-content"> <div class="instant-updates-bellicon"> <i class="updates-bellicon"></i> </div> <span>Get Instant News Updates</span> </div> <div class="instant-updates-arrow">Enable</div> </div> <span class="instant-updates-close">x</span> </div> </div> <div class="article-overlay"></div> <div class="notification-settings-popup"> <a href="javascript:void(0);" class="notification-settings notfset"><i class="fa fa-arrow-left"></i> Notification Settings</a> <a href="javascript:void(0);" class="article-popup-close">X</a> <div class="notification-overflow"> <div class="notification-settings-content"> <div class="notification-settings-heading">Time Settings</div> <div class="notification-settings-details clearfix"> <ul> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="0" type="radio" checked="checked"> <i for="squaredradio"></i> </div> <span class="name">Don't Block</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="8" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Block for 8 hours</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="12" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Block for 12 hours</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="24" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Block for 24 hours</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="1" type="radio"> <i for="squaredradio"></i> </div> <div class="name">
Dont send alerts during
<select class="alerts-time-selbox" id="block-from" name="" disabled="disabled"> <option value="1">1 am</option> <option value="2">2 am</option> <option value="3">3 am</option> <option value="4">4 am</option> <option value="5">5 am</option> <option value="6">6 am</option> <option value="7">7 am</option> <option value="8">8 am</option> <option value="9">9 am</option> <option value="10">10 am</option> <option value="11">11 am</option> <option value="12">12 pm</option> <option value="13">1 pm</option> <option value="14">2 pm</option> <option value="15">3 pm</option> <option value="16">4 pm</option> <option value="17">5 pm</option> <option value="18">6 pm</option> <option value="19">7 pm</option> <option value="20">8 pm</option> <option value="21">9 pm</option> <option value="22">10 pm</option> <option value="23">11 pm</option> <option value="24">12 am</option> </select>
to
<select class="alerts-time-selbox" id="block-to" name="" disabled="disabled"> <option value="1">1 am</option> <option value="2">2 am</option> <option value="3">3 am</option> <option value="4">4 am</option> <option value="5">5 am</option> <option value="6">6 am</option> <option value="7">7 am</option> <option value="8">8 am</option> <option value="9">9 am</option> <option value="10">10 am</option> <option value="11">11 am</option> <option value="12">12 pm</option> <option value="13">1 pm</option> <option value="14">2 pm</option> <option value="15">3 pm</option> <option value="16">4 pm</option> <option value="17">5 pm</option> <option value="18">6 pm</option> <option value="19">7 pm</option> <option value="20">8 pm</option> <option value="21">9 pm</option> <option value="22">10 pm</option> <option value="23">11 pm</option> <option value="24">12 am</option> </select> </div> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="9999" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Switch Off</span> </label> </div> </li> </ul> </div> <span id="error_msg"></span> </div> <div class="notification-settings-bottomcontent"> <div class="notification-settings-clear"> <div class="notification-settings-heading" id="clear-inbox" style="display: none;">Clear My <a href="javascript:void(0);">notification inbox</a></div> </div> </div> <div class="notification-settings-btn">
Done
</div> </div> </div> <div class="notification-settings-clearbox"> <a href="javascript:void(0);" class="notification-settings clearnotf"><i class="fa fa-arrow-left"></i> Clear Notification</a> <a href="javascript:void(0);" class="article-popup-close">X</a> <div class="notification-overflow-clearbox"> <div class="notification-settings-heading">Do you want to clear all the notifications from your inbox?</div> </div> <div class="notification-settings-btn"> <a href="javascript:void(0);" class="yes">Yes</a> <a href="javascript:void(0);" class="no">No</a> </div> </div> <div class="article-slider-wrapper"> <a href="javascript:void(0);" class="article-popup-settings">Settings</a> <a href="javascript:void(0);" class="article-popup-close">X</a> <div class="article-slider"> <ul id="notification-content"> </ul> </div> <div class="article-slider-container" style="display: none;"> <div class="no-notification-wrapper"> <div class="no-notif-content"> <span>0</span> </div> <div class="no-notif-text">No New Notifications</div> </div> </div> </div> <div data-id="3" data-step="1" class="oneindia_widget_container" id="oneindia_widget_container_1328"></div> <div class="bd-video-overlay" style="display: none;"></div> <div class="bd-video-popup"> <div class="bd-main-video-wrap"> <div class="bd-mainvd-title" id="PlayerTitle"></div> <a href="javascript:void(0);" class="bd-video-close">X</a> <div class="bd-mainvd-img"><div id="dmPopPlayer" style="height: 100%;"></div></div> <div class="videos-share-links clearfix" id="videos-share-links" data-share-url="" data-share-title="" data-share-image=""> <a href="#" class="share-fb"><i class="fa fa-facebook"></i></a> <a href="#" class="share-twitter"><i class="fa fa-twitter"></i></a> </div> </div> <div class="bd-popup-related-video-container"> <ul id="PopSlider"> </ul> </div> </div> <div class="lightbox-videos-overlay"></div> <div class="lightbox-popup-videos-wrapper"> <div class="lightbox-popup-videos-close"><a href="javascript:void(0);">Close <i class="fa fa-times"></i></a></div> <div class="lightbox-popup-videos-container-parent"> <div class="lightbox-popup-videos-container"> <div class="lightbox-popup-videos-left"> <div class="lightbox-popup-video" id="lightbox-popup-video"> </div> <div class="lightbox-popup-video-heading"> <span id="lightbox-popup-video-heading"></span> <div class="lightbox-popup-videos-socialinks" id="lightbox-videos-share-links" data-share-url="" data-share-title="" data-share-image=""> <a href="#" class="social-icons facebook light-share-fb"><i class="fa fa-facebook"></i></a> <a href="#" class="social-icons twitter light-share-twitter"><i class="fa fa-twitter"></i></a> </div> </div> </div> <div class="lightbox-popup-videos-right"> <div class="lightbox-popup-ad" id="lightbox-popup-ad"></div> </div> <div class="lightbox-popup-clear"></div> </div> </div> <div class="lightbox-popup-morevideos" id="lightbox-popup-morevideos"> <ul class="oneindia-fl-videos"></ul> <ul class="filmibeat-fl-videos"></ul> <ul class="boldsky-fl-videos"></ul> </div> </div> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init','407111549682023');fbq('track','PageView');</script> <div style="position: fixed; right:0px; bottom:0px;z-index:999999999;"><iframe style="border:0;scrolling:none;height: 105px;width:115px;" src="https://www.boldsky.com/common/corona/corona-virus-flip.html"></iframe></div> </div> </div> </div> <script type="text/javascript">var d=new Date();var n=d.getMilliseconds();var urlburst='v='+n;if(window.location.search==='?staging'){var conFile='/common/oijs/oiframework-desk-app-stag.js?'+urlburst;}else{var conFile='/common/build/js/oiframework-desk-app.min.js?v=1.0.420';}['/common/app/lib/require-latest.js',conFile].forEach(function(src){var script=document.createElement('script')
script.src=src;script.async=false;document.head.appendChild(script);});</script> <script>var ga_ad_block="ad block";var hostname=window.location.hostname;var oiab_done=false;function loadScript(path,callback){var scr=document.createElement('script');scr.onerror=handleError;scr.async=true;scr.src=path;document.body.appendChild(scr);function handleError(){console.log('handleError');if(!oiab_done){oiab_done=true;loadwhenAB();}}}loadScript("https://"+hostname+"/common/js/ads.js");function loadwhenAB(){console.log('inside AB function');if(document.getElementById('zQyHLKpYGvgh')){console.log('Without Ad Blocker');}else{ga('boldskyen.set','dimension5',ga_ad_block);(function(){var today=new Date();var urlBurstParam=today.getHours();var commontag=document.createElement('script');commontag.src='https://rss.oneindia.com/common/oi-inhouse-scripts.js?lang=en&domain='+hostname+'&v='+urlBurstParam;commontag.async=true;commontag.id='oiinhousescripts';var firstcommonScriptTag=document.getElementsByTagName('script')[0];firstcommonScriptTag.parentNode.insertBefore(commontag,firstcommonScriptTag);}());}}</script> <div class="non-friendly-scatter"> <div id="zbe439884-7c2f-407b-8199-5ffb763e019e" style='display:none'></div> </div> <noscript><img height="1" width="1" alt="FB pixel" style="display:none" src="https://www.facebook.com/tr?id=407111549682023&ev=PageView&noscript=1"/></noscript> <noscript> <img src="https://b.scorecardresearch.com/p?c1=2&c2=7732551&cv=2.0&cj=1" alt="scorecardresearch"/> </noscript> <noscript> <div style="display: none;"> <img src="//pixel.quantserve.com/pixel/p-yjta2aSVPaHEL.gif" height="1" width="1" alt="Quantcast"/> </div> </noscript> <script type="text/javascript">if(document.getElementById("container")){var content_id=document.getElementById("container").getAttribute('data-content_id');if(content_id==121129){var imagePromo=document.createElement("img");imagePromo.setAttribute("src","https://ad.doubleclick.net/ddm/activity/src=8470986;type=bolds0;cat=bolds0;u1=PDP0003;u2=ART0029;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;ord=1");document.head.appendChild(imagePromo);}else if(content_id==121397){var imagePromo=document.createElement("img");imagePromo.setAttribute("src","https://ad.doubleclick.net/ddm/activity/src=8470986;type=bolds0;cat=bolds0;u1=PDP0003;u2=ART0030;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;ord=1");document.head.appendChild(imagePromo);}else if(content_id==121798){var imagePromo=document.createElement("img");imagePromo.setAttribute("src","https://ad.doubleclick.net/ddm/activity/src=8470986;type=bolds0;cat=bolds0;u1=PDP0003;u2=ART0031;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;ord=1");document.head.appendChild(imagePromo);}}</script> <script type="text/javascript">function getBrowserName(){var name="";if((/(chrome\/)(\d+\.\d+)/i.test(navigator.userAgent)&&navigator.userAgent.search("UCBrowser")<0)&&(/(chrome\/)(\d+\.\d+)/i.test(navigator.userAgent)&&navigator.userAgent.search("Edge")<0)&&(/(chrome\/)(\d+\.\d+)/i.test(navigator.userAgent)&&navigator.userAgent.search("UBrowser")<0)){name="Chrome";}else if(navigator.userAgent.indexOf("MSIE")!=-1){name="MSIE";}else if(navigator.userAgent.indexOf("Firefox")!=-1){name="Firefox";}else if(navigator.userAgent.indexOf("Opera")!=-1){name="Opera";}else if(navigator.userAgent.indexOf("Safari")!=-1){name="Safari";}return name;}function trackEventsforExtension(){ga('boldskyen.send','event','cms-plugins','extn-addon',label);}var browserCheck=getBrowserName();var label;if(browserCheck==='Chrome'){var current_link='https://chrome.google.com/webstore/detail/oneindia-news/koechefapcepkbkbbjcfdaeppoiophnd?hl=en';document.querySelector(".browser_extension").setAttribute('href',current_link);label='chrome';document.querySelector(".extensionElem").style.display='block';}else if(browserCheck==='Firefox'){var current_link='https://addons.mozilla.org/en-GB/firefox/addon/oneindia-news/';document.querySelector(".browser_extension").setAttribute('href',current_link);label='firefox';document.querySelector(".extensionElem").style.display='block';}var clickObj=document.querySelector(".browser_extension");clickObj.onclick=trackEventsforExtension;</script> <iframe id="multisync-iframe" height="0" width="0" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" src="https://secure-assets.rubiconproject.com/utils/xapi/multi-sync.html?p=dfp&endpoint=apac" style="border: 0px; display: none;"></iframe> <script>if(document.getElementById("right-native-ad")){var slotpos='rightInclude';var tcode='RB';}else if(document.getElementById("oiNativePromo1")){var slotpos='homeInclude';var tcode='HP';}else{var slotpos='indexInclude';var tcode='IP';}(function(){var host='BSEN';var lang='en';var randomh=Math.random();var curl=window.location.href;var e=document.getElementsByTagName("script")[0];var d=document.createElement("script");d.src="https://rss.oneindia.com/common/render-native-ad.js?slotpos="+slotpos+"&lang="+lang+"&host="+host+"&curl="+curl+"&trackcode="+tcode+"&v="+randomh+"";d.type="text/javascript";d.async=true;d.id="nativeadjs";e.parentNode.insertBefore(d,e);})();</script> <script>function createCookie(name,value,days){if(days){var date=new Date();date.setTime(date.getTime()+(days*24*60*60*1000));var expires="; expires="+date.toGMTString();}else var expires="";document.cookie=name+"="+value+expires+"; path=/";}function eraseCookie(name){createCookie(name,"",-1);}function removeCookies(){var cookies=document.cookie.split(";");for(var i=0;i<cookies.length;i++){eraseCookie(cookies[i].split("=")[0]);}}var chkcookiepolicy=getUserCookie('cookiePolicy');console.log(chkcookiepolicy+" : Country Found");if(typeof(chkcookiepolicy)=="undefined"||chkcookiepolicy==null){setUserCookie('cookiePolicy',1,'','/','','');}</script> <script>if(document.getElementById("adg_related_right")){document.getElementById("adg_related_right").innerHTML='<li class="clearfix"><div class="adg_native_home" data-templateId_slotId="943_0" data-nanoNativeFlag="1" style="display:none;"><a href="#" class="nano_promo_right_a"><img src="#" class="nano_promo_right_img"></a></div></li>';}</script> <script>(function(){var today=new Date();var urlBurstParam=today.getDate();var tag=document.createElement('script');tag.src='https://rss.oneindia.com/common/oi-settings.js?lang=en&v='+urlBurstParam;tag.async=true;tag.id='oiscripts';var firstScriptTag=document.getElementsByTagName('script')[0];firstScriptTag.parentNode.insertBefore(tag,firstScriptTag);}());</script> <script type="text/javascript" data-pagespeed-no-defer>(function(){var hidden="hidden";if(hidden in document)document.addEventListener("visibilitychange",onchange);else if((hidden="mozHidden")in document)document.addEventListener("mozvisibilitychange",onchange);else if((hidden="webkitHidden")in document)document.addEventListener("webkitvisibilitychange",onchange);else if((hidden="msHidden")in document)document.addEventListener("msvisibilitychange",onchange);else if("onfocusin"in document)document.onfocusin=document.onfocusout=onchange;else
window.onpageshow=window.onpagehide=window.onfocus=window.onblur=onchange;function onchange(evt){var v="visible",h="hidden",evtMap={focus:v,focusin:v,pageshow:v,blur:h,focusout:h,pagehide:h};evt=evt||window.event;if(evt.type in evtMap)document.body.className=evtMap[evt.type];else
document.body.className=this[hidden]?"hidden":"visible";}if(document[hidden]!==undefined)onchange({type:document[hidden]?"blur":"focus"});})();</script> <script type="text/javascript">var adElem=[];var adObj={};googletag.cmd.push(function(){googletag.pubads().addEventListener('slotRenderEnded',function(event){var slotId=event.slot.getSlotElementId();var slotName=event.slot.getAdUnitPath();adObj[slotName]=slotId;});adElem.push(adObj);});console.log("DFP AD units: ");console.log(adElem);</script> <script type="text/javascript">var breakInt;var chkadcookie=getUserCookie('ad_display_status');var sub_id=localStorage.getItem("bsenglish_subscription_id");if(chkadcookie==null||chkadcookie==undefined||chkadcookie==''){chkadcookie='';}var chkadcookiemor=localStorage.getItem('ad_display_status_mor');if(chkadcookiemor==null||chkadcookiemor==undefined||chkadcookiemor==''){chkadcookiemor='';}var chkadcookieeve=localStorage.getItem('ad_display_status_eve');if(chkadcookieeve==null||chkadcookieeve==undefined||chkadcookieeve==''){chkadcookieeve='';}var camp_id=localStorage.getItem("ad_campiagn");if(camp_id==null||camp_id==undefined||camp_id==''){camp_id='';}var displayFlag=0;var dynamicNotification={createAdCookie:function(name,value,days){if(days){var date=new Date();date.setTime(date.getTime()+(days*24*60*60*1000));var expires="; expires="+date.toGMTString();}else var expires="";document.cookie=name+"="+value+expires+"; path=/";},displayNotification:function(body,icon,title,link,duration,slotFlg,currentDay,adCamp){link=link||0;duration=duration||3000;icon=icon+'?url='+link;var options={body:body,icon:icon};navigator.serviceWorker.ready.then(function(registration){registration.showNotification(title,options);if(slotFlg==0){localStorage.setItem('ad_display_status_mor',currentDay);}else{localStorage.setItem('ad_display_status_eve',currentDay);}localStorage.setItem('ad_campiagn',adCamp);});},displayTime:function(){var displayHourMor=[8,13];var displayHourEve=[15,23];var theDate=new Date();var currentDay=Math.abs(theDate.getDate());var currentHour=Math.abs(theDate.getHours());if((currentHour>=displayHourEve[0]&&currentHour<=displayHourEve[1])&&(chkadcookieeve==''||chkadcookieeve!=currentDay)){clearInterval(breakInt);dynamicNotification.checkStatus(1,currentDay);}},fetchDynamicAd:function(sub_id,slotFlg,currentDay){var no_ads=1;fetch("/scripts/cms/controller.php?module=subscription&type=getAdgebraAd&last_sub_id="+sub_id+"&device_type=1&noAds="+no_ads+"&campid="+camp_id,{method:"post"}).then(function(e){e.text().then(function(data){adgebraResponse=data;if(adgebraResponse!=''&&adgebraResponse!=undefined){var adgRes=JSON.parse(adgebraResponse);if(adgRes[0]!=''&&adgRes[0]!=undefined&&adgRes[0]!=null){var adgUrl=decodeURIComponent(adgRes[0]['trackerUrl']).replace(/\+/g,' ');var adgImg=adgRes[0]['notificationImage'];var adgTitle=decodeURIComponent(adgRes[0]['notificationMessage']).replace(/\+/g,' ');var adCamp=adgRes[0]['campId'];dynamicNotification.displayNotification(adgTitle,adgImg,adgTitle,adgUrl,3000,slotFlg,currentDay,adCamp);}}});})["catch"](function(e){console.log("Fetch Error :-S",e)});},checkStatus:function(slotFlg,currentDay){if(sub_id!=""&&sub_id!=undefined&&sub_id!=null){dynamicNotification.fetchDynamicAd(sub_id,slotFlg,currentDay);}},init:function(){if("Notification"in window){var permission=Notification.permission;var userStatus=navigator.onLine;console.log(permission+" User is :"+userStatus);if(permission==="denied"){return;}else if(permission==="granted"&&userStatus){breakInt=setInterval("dynamicNotification.displayTime()",10000);}}}};var qparam=window.location.search;dynamicNotification.init();</script> </body> </html>